Dakota Durango Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1 (Edited)
Primary concern: New battery goes dead if D sits for a week. However, if run every day the drain is slow enough that it will start each morning.

Super weird side behavior: while driving at night, on the course of a 10 minute well traveled route, no less than three (3) times all of these things happened at exactly the same moment:

  • Instrument cluster went dark, reset, came back up
  • Radio (REC nav) rebooted to Dodge logo then came back up
  • Temperature in overhead console immediately changed to -40F

However:

  • No loss of engine power or throttle, stayed running
  • Headlights did not even blink

Now I think I might have found what’s draining my battery, but it still doesn’t explain the other stuff above. After connecting my NoCo 10 Amp to recharge the battery, I started the vehicle for awhile and then shut it back off. I locked it, interior lights went off, but then a second after the interiors went off, the HVAC (auto climate, has buttons not knobs) lit back up! What in the world!

I did not hear any blower running from outside the car, I unlocked, and as soon as I opened a door, the screen of it went off! No misbehavior from radio, instrument cluster, or overhead console during that particular event.

So I disconnected a battery cable in between drives. Any ideas where to start looking or how to test?


Sent from my iPhone using Tapatalk
 
1 - 1 of 1 Posts
Top