Dakota Durango Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Dont know if anyone else has had this problem. When I turn on my turn signals, they will flash maybe 3 times if Im lucky, then go off, even tho the stalk is still down. If I jam it down very hard, left one will stay on, but the right one wont no matter what. I want to see what the problem could be before I take it in for service. Its not bulbs, all work fine, and the stalk doesnt pop back up or anything, it will stay down, just apparently not far down enough to activate the turn signals more than a couple times. Any help would be appreciated!
 

·
I bleed MOPAR!!!!!!!!!!!!
Joined
·
134 Posts
Hey Michelle,

Sounds like your multifunction switch is going bad.

Good sign when turn signals do all sorts of wierd stuff.
Probaly run you a pretty penny if you took it in to a dealer.
It's not to hard to due either
A couple of screws to hold on a plastic piece of trim and a few connectors and two screws and its out.
Sorry for the vague details.

Oh by the way I noticed you are from Lombard. Good to see a local (Live in Woodridge ) on this site.
Hope this helps Kevin
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Thanks Demon,
I got a warranty on it when I bought it, but I still hate ever going to the dealership, cuz then they go 'Oh its a girl, lets sell her things she doesnt need' lol. And are they surprised when they do try that, lol. Well Ill fix that switch and see what happens. Hope that does it, if not, on to something else. What kind of truck do you have? Ever drive through Lombard?
 

·
I bleed MOPAR!!!!!!!!!!!!
Joined
·
134 Posts
Good call with the warranty.

Hopefully they will cover it.

I can see where your coming from with the whole girl in dealership thing. Depending on where you go you will always get someone to try and rip you off.

I drive a '98 Dakota 3.9 auto 2wd "work truck"
I put a LSD rear in.
It's white with a black snap tonneau.
Nothing too exciting.
Like I said a work truck.

I go through Lombard every so often. But mainly stick around Downers Grove area.
Kevin
 

·
Registered
Joined
·
1,177 Posts
sounds like your flasher unit is going bad. If you look straight up from your E brake you can see it. It's at the very top of that hidden fuse panel
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
71_Demon said:
Good call with the warranty.

Hopefully they will cover it.

I can see where your coming from with the whole girl in dealership thing. Depending on where you go you will always get someone to try and rip you off.

I drive a '98 Dakota 3.9 auto 2wd "work truck"
I put a LSD rear in.
It's white with a black snap tonneau.
Nothing too exciting.
Like I said a work truck.

I go through Lombard every so often. But mainly stick around Downers Grove area.
Kevin
Gotcha, I used to go thru woodridge on my way to school in burr ridge, but havent been around there lately. And helpng people move :rant: lol. I got a 2000 dak R/T, havent modded it yet, I just got it in February, and all my extra money is going into my other truck. The Dak was supposed to be a driver when the other one was being worked on. Lol, now I like the dakota better than the other truck.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
rockadaous said:
sounds like your flasher unit is going bad. If you look straight up from your E brake you can see it. It's at the very top of that hidden fuse panel
Thanks Rock, I was gonna tear into it today to see what exactly the problem was but its too damn hot outside today...Guess Im waiting until next weekend. But thanks for the info, Ill check that out too. Eh F*k the heat ive been outside all day, guess ill check it now :clap2:
 

·
Registered
Joined
·
1,177 Posts
I have a picture some where. you can pick another one from auto-zone. take the old one with you
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top