Dakota Durango Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
60 Posts
Discussion Starter · #1 ·
So I'm sitting in traffic today and suddenly the CEL comes on. Completely boggled my mind. Then, I go to take off and the truck is sluggish as all hell... no torque what-so-ever. After about 10 minutes, I realize that for some reason the truck isn't downshifting into 1st when I stop. So, I try to manually do it. Nothing, just goes to 2nd. I've had a tiny leak from my tranny pan gasket for a while now, but it might drip 2 drips a night. I check my tranny fluid periodically and even today it is still full. I'm getting a friends scanner tonight to see what code(s) are thrown. Anyone have any ideas or has anyone experienced this before? If my name doesn't give it away, I have a 2001 R/T.
 

· Registered
Joined
·
60 Posts
Discussion Starter · #3 ·
BlueSport... thanks for that link! Well, here's the code I threw.

P1762 (M) GOV Pressure Sen Offset Volts Too Low Or High The Governor Pressure Sensor input greater or less than calibration for 3 consecutive Neutral/Park calibrations.
P1762 (M) Governor Pressure Sen Offset Volts Too Low Or High Sensor input greater or less than calibration for 3 consecutive Neutral/Park occurances. (4-speed auto. Trans. Only)

After some searching for that code on here, I'm assuming I have to replace the governor solenoid and pressure switch? Wonderful...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top