Dakota Durango Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5,697 Posts
Discussion Starter #1
2001 QC, 4.7 auto 4x4

Idle is on the verge of being rough, something is not right. No engine light or anything, but I am wondering if there is something I should be cleaning, etc to help with this. It seems to be getting worse, as well. I definitely notice it at lights, and when I start to move after sitting at a light, it doesn't start rolling on it's own, I have to give it gas, as if it was in nuetral while sitting or something. I am used to releasing the brake and having it roll forward right away, but it's not happening right now.

The trans shifts funny while slowly accelerating. It feel like it is shifting into the next gear too early, and causes it to clunk into gear. Happens at all gears. Any ideas?

MPG is currently reading as 14.8. Is there anything I can do to improve this? I just changed the oil to a synthetic blend and the plugs are new. I am running an FIPK.

All help is appreciated.
 

·
Juice Junky
Joined
·
2,086 Posts
BlackDak said:
MPG is currently reading as 14.8. Is there anything I can do to improve this? I just changed the oil to a synthetic blend and the plugs are new. I am running an FIPK.
New exhaust should bump it up a bit.
 

·
Banned
Joined
·
7,509 Posts
well with my truck when I let off the brakes the truck likes jerks or surges fwd. its not a smooth take off. but when I get up to about 5mph it stops. I took it to the dealer and they told me its normal for it to do that. I cant buy that but I cant make them fix something they say isnt bad. I was thinking about taking it to another dodge place. the place I took it to is a 5 star dealership. it gets frustrating at times feeling that surge. also on a hill when I release the brakes the truck will roll backwards. I thought auto trans ddint do this? I dont know about this as all my vehicles has been manuals.

it does it in 2wd 4hi but in 4 low it doesnt do it. it smooth when I release the brakes.
 

·
Registered
Joined
·
199 Posts
BlackDak said:
2001 QC, 4.7 auto 4x4

Idle is on the verge of being rough, something is not right. No engine light or anything, but I am wondering if there is something I should be cleaning, etc to help with this. It seems to be getting worse, as well. I definitely notice it at lights, and when I start to move after sitting at a light, it doesn't start rolling on it's own, I have to give it gas, as if it was in nuetral while sitting or something. I am used to releasing the brake and having it roll forward right away, but it's not happening right now.

The trans shifts funny while slowly accelerating. It feel like it is shifting into the next gear too early, and causes it to clunk into gear. Happens at all gears. Any ideas?

MPG is currently reading as 14.8. Is there anything I can do to improve this? I just changed the oil to a synthetic blend and the plugs are new. I am running an FIPK.

All help is appreciated.
It does sound like the good old Throttle Postion Sensor. I have to replace mine also, probably do that today!!
 

·
Registered
Joined
·
5,697 Posts
Discussion Starter #6
I was kind of leaning that way as well. I have also heard something about cleaning the IAC valve?

How much are they getting for the TPS, and is there a favorite brand around here?
 
1 - 6 of 6 Posts
Top