Dakota Durango Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I have a 2000 dakota r/t. The problem I'm having is at 60 to 65 mph the tranny wants to shift back and forth from third to forth.Is this normal can anyone help very frustated. THanks
 

· Registered
Joined
·
285 Posts
ret7268 said:
I have a 2000 dakota r/t. The problem I'm having is at 60 to 65 mph the tranny wants to shift back and forth from third to forth.Is this normal can anyone help very frustated. THanks
How long has it been since you've changed the fluid and filter? I'd do that first and see if the problem goes away.
 

· Registered
Joined
·
1,177 Posts
could be a couple of things
make sure your tranny fluid is correct
it could also be your TPS. $40 at NAPA. real easy to change.
 

· Montana Dodge's BFF
Joined
·
1,533 Posts
What they said and also the output shaft speed sensor could cause those synptoms.I would do a fluid and filter change(if you haven't done it in a while) and then check the Throttle Position Sensor.With it being speed related I would also check the Output shaft speed sensor too.



DEPUTY
 

· Home Owner....
Joined
·
1,722 Posts
are ya gettign a check engine light yet?? do a fluid/filter change (MOPAR ATF4) and grab a output speed sensor.

if that dont do the trick, could be the OD unit has taken a dump.... :sorry: :cussing:
 
G

·
Discussion Starter · #6 ·
output shaft speed sensor will trigger "checkengine light". If this has happened, it is under $15 bucks and easy to change out.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top