Dakota Durango Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
First let me introduce myself, My name is Paul and i am from Marlborough, Mass. I own a 1999 Dodge Dakota Club Cab with 4 wheel drive. Havent done any mechanical changes to the truck but i have dressed it up a little with side bars and full bug shield. I drive it 80 miles a dat to and from work. Recently it has been stalling on my when i come off the highway. So i brought it to the dealer because the engine light has come on. They said it was the Map sensor. So they replaced it. Well $180.00 later, that wasnt the problem. I came to this web site when looking for help. I have read a few good threads about the IAC Sensor. So last night i replaced it. Unfortunately that wasnt the problem. So i am still looking for answers. Here is an overview of my problem in better detail. First, i had the waterpump replaced about a month ago. It was making a ton of noise and the berrings where shot. 3 days later i had the water pump by pass hose replaced. This threw fluid everywhere under the hood. Sorry, prior to this i was putting my boat in the water and my differential got full of water. Now my ABS and brake light on the cluster is constantly on and my speedometer is jumping all over the place. Any way. The stalling only occurs when i am slowing down to a stop in first gear. The rpms drop and then the engine stalls. I usually throw it in nuetral and keep my foot on the pedal a little to keep it running. Sometimes it runs great. I just dont understand it. Please help.
 
1 - 1 of 1 Posts
Top