Dakota Durango Forum banner
1 - 5 of 5 Posts

·
Eatin' Ford Shittin Chevy
Joined
·
325 Posts
Discussion Starter · #1 ·
i have a 99 318 4WD and its been running funny the last two days.

whenever ill be running it for any period of time and come to a stop, the RPM's will drop to about 550-600 and it will feel like its about to die, almost like if you were driving a stick and you were about to kill it. Like it'd shake then go again like normal.

I tried tightening the pulleys because it seemed some of them were loose, that didnt fix the problem.

my oil level is fine.

If you need any other questions answered, just ask.
 

·
sixpack
Joined
·
104 Posts
I experienced a similar problem in August with my 99 5,9 at some 70k miles. Mine also had rough idle while warm. I changed the pre-cat O2-sensor and everything has been fine since. I had no Check Engine codes, just a friend's advice about the O2.
 

·
Armed and Dangerous
Joined
·
2,475 Posts
My first thought is an o2 sensor as well. No CEL I take it?
 

·
Eatin' Ford Shittin Chevy
Joined
·
325 Posts
Discussion Starter · #4 ·
yeah no CEL. i guess ill buy one of them fuckers too. should get the one with the air fuel ratio gauge too and drop $300 on that thanks to our friends at autometer.
 
G

·
Before you go spending a lot of money on a new O2 sensor you may not need, stop by the parts store and pick up a can of spray carb cleaner and a new TB gasket...about $5. Remove and throughly clean the TB especially the tip of the IAC sensor and the IAC sensor port on the TB. Be careful not to push or pull on the tip or you'll get it out of adjustment. Carbon buildup and all that gummy crap will make for some very bad idling issues and all you have invested is about $5 and about 30 minutes of your time. If this don't improve your situation, then think about replacing the O2 sensor.
 
1 - 5 of 5 Posts
Top