Dakota Durango Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I read somewhere that there was a problem with the durango passenger side rear power windows not working. All the other windows work but nothing on this one. I worked for a while and now nothing. Anyone heard of this problem? :help:
 

·
Registered
Joined
·
150 Posts
What happens if you were to take the wires going to that motor and touch them to the battery from a cordless dirll? does it go up/down then?

My front passenger window does this. There's a gear I need to replace in the motor. But, my window works just fine, so I'm not too worried about it. :) But, I'm also thinking of jsut getting a refurbished motor off the internet instead of working on the motor myself. I dunno.
 
G

·
Most likely it just needs a motor brush that you can pick up at a hardware store. A couple of bucks, match up the brush with the one in your window motor and you're golden.
 

·
Registered
Joined
·
150 Posts
Coach said:
Most likely it just needs a motor brush that you can pick up at a hardware store. A couple of bucks, match up the brush with the one in your window motor and you're golden.
I don't suppose you have a pic of said motor brush. I wouldn't really know what I'm looking for in the motor.
 
G

·
Unfortunately not, however if you take out the screws that hold the motor together you will see what looks like a spring with a longish black piece on the end attached to it. That's the piece that needs to be replaced. Clean up the opening a bit before re-installing.
 

·
Registered
Joined
·
150 Posts
Wow...that's an excellent thread to let me know what I'm looking for. But, I guess I'm still going to have to find my Haynes manual so I can read how to properly take the regulator and motor out. Hopefully the book will also have a section about lubricating the regulators. Might as well do that while I have it out.
 

·
Registered
Joined
·
1 Posts
Hi guys

well my rear driver side window will not go up or down with either switch, i already replaced both the rear and the main switch and still nothing, I do have power all the way to the motor. When i added power directly to the motor itself it went down and up perfectly, but when i went to try it again it doesnt do anything plus the window motor gets super hot, Do you guys think its the motor that i need to replace?
 

·
Registered
Joined
·
37 Posts
if the motor gets "super hot" then it may need replacement because it is drawing alot of current which is where the heat is coming from... also while you are in there it would be a good idea to LIGHTLY coat the moving parts with a high grade grease or a good dry film lubricant
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top