Dakota Durango Forum banner
1 - 6 of 6 Posts

·
Bomb Technician.
Joined
·
202 Posts
Discussion Starter · #1 ·
my 00 4.7 dak dak the powersteering pump go out on it. I replaced it with a brandnew one and all was fine the first day. well today i get in my truck and notice the steering is getting stiff. I check the fluid and sure enough it was low. So i topped the fluid off and i drive to town. Steered fine for about a half mile and then it felt like there was no powersteering pump at all. Pull over and check and sure enough its bone dry. Wtf could have went wrong when it worked fine the first day i had it on?
 

·
Bomb Technician.
Joined
·
202 Posts
Discussion Starter · #3 ·
Where is all of the fluid going? Is one of the lines slightly loose? Is it making a "mess"?
man i torqued the High pressure line down tight as hell on the bottom side of the pump but thats where it looks like the fluids coming from. im afraid if i try to tighten it up any more ima strip sumthing. But it literally will empty the system in 5 minutes or less
 

·
Bomb Technician.
Joined
·
202 Posts
Discussion Starter · #7 ·
everything look completely identicle bro. thats why im at a loss. is there a wrong kinda fluid you can put in them? cuz i used plain jane power steering fluid with a lil bith of lucas power steering fluid. Would the lucas or the orielly brand PS fluid have fucked sumthing up?
 

·
Bomb Technician.
Joined
·
202 Posts
Discussion Starter · #9 ·
Im so fucking stupid man. The line worked it self loose although i dont see how because i put damn near all 200 pound of my body into that thing when i tightend it. I guessi just panic'd and instead of double checking it just went ape shit. Thanks for the help bro.
 

·
Bomb Technician.
Joined
·
202 Posts
Discussion Starter · #11 ·
Ok problem is back although its not leaking anywhere near as bad as before and it also looks like its coming from higher up the pump because when i wipe off the fluid it looks as if its running down the side of the pump from somewhere then down the Pressure line. Its a very small leak so i dont think its anything major, just annoying considering its all band new. Any ideas?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top