Dakota Durango Forum banner

21 - 26 of 26 Posts

·
Registered
Joined
·
99 Posts
That is interesting, my gut response would be the connectors may have corrosion on them, causing the intermittent issue. Instead of unplugging them and plugging them back in, have you tried "wiggling" them to see if you get the same "fix" result?

I HIGHLY recommend buying a can of DEOXIT 100 contact cleaner (you can get it from Guitar Center), and spraying your PCM molex plugs and PCM molex ports.

Also, I still have a new PCM for my 2001 Automatic Transmission/4.7L/With A/C and California Emissions, you are more than welcome to have it, if it will work for your year and model.

You will need to take it to someone that has a DRB-III or suitable tool to program your VIN into it.
Only question I have in response is, would it be compatible with a 99 5.9L SLT PLUS?
 

·
Registered
Joined
·
23 Posts
Computer

I JUST WENT THRU THE SAME THING FOR QUITE SOMETIME. (THE LAST 3 YEARS). I WENT THRU 3 CAMSHAFT SENSORS,3 BATTERIES,3DISTRIBUTORS AND 2 COMPUTERS. HAPPENED TO KEEP CUTTING OFF.. GUSE WHAT WAS THE PROBLEM? THE TWO GROUND WIRES FROM THE FIREWALL HAD RUSTED AWAY FOR WHAT EVER REASON. PURCHASED NEW ONES AND TRUCK STARTED AND RAN SMOOTH AND HAS NEVER SHUT DOWN . CHECK YOUR GROUND WIRES!!! I ALMOST GOT RID OF MY DURANGO RT!! THANK GOD I FOUND THIS OUT!! :woot:
 

·
Registered
Joined
·
24 Posts
Which 2 ground wires??????? can you post a pic..... sorry for the late post...
 

·
Registered
Joined
·
199 Posts
Necropost: Where did you find this frayed wire? I've got the same code and a slew of transmission problems as well as a slew of body rust. I hear talk of a bundle of wires above the parking brake getting frayed, and a bad ground wouldn't surprise me one bit.
 

·
Registered
Joined
·
194 Posts
FYI- If you're interested in rebuilding your PCM


For firewall ground

 
21 - 26 of 26 Posts
Top