Dakota Durango Forum banner

1 - 3 of 3 Posts

·
110 HP, 11.1 MPG. FML
Joined
·
4,370 Posts
Discussion Starter #1
so i had a 185* t-stat in until recently, and my gauge always read a tad cold for obvious reason. well, a few months ago i wanted to swap back to a 195* for both better MPG and better heat, and after a parts counter fuckup where he gave me a 180*, i now have the 195* back in, new heater hoses and a new radiator cap.
now here is the issue
if i let it idle, it will come up to temp fine and my e-fan comes on just past the gauge center. if i'm driving though it will come up to about 2/3s to the center of the gauge and then fall down to half way between the center and cold. now i did the efan swap about a week before this so im not sure if it did it before the t-stat change, but could it be that becasue my efan covers less surface area than the fan shroud used to that it's doing this when im driving?
i really want to try to exhaust all other options before swapping the tstat again because that's a bitch to do...
now there allways seems to be air in the top of my radiator too, and i have been filling it up, but could that be more than just air working it's way out?
the old radiator cap held NO pressure, i tested it at school, the system held 16lbs with no leaks and the new cap held 16lbs too, but idk, it feels like its... loose? not like holy shit it's gonna fall off, but it's not really TIGHT when it's cold like the old one was... could this be part of the issue?
 

·
.:.:.:.:.:.:.:.
Joined
·
10,424 Posts
The t-stat should be keeping the temp in the right range...it'll stay closed until it gets there.

Sounds like either a t-stat sticking open or you may still have air in the system.
 

·
110 HP, 11.1 MPG. FML
Joined
·
4,370 Posts
Discussion Starter #3
i looked at the radiator tonight, it's full but i know there is just a few burps in there i need to get out (rad cap has a few points level with it...) but would that really matter becasue they are in the upper hose and the rad, and the tstat is submerged?
i have had 0 luck with starting it up and burping it, so if it is air idk what to do...

any way to TEST if it is the tstat?
my issue is, is that i have no warm place to work on it and it is a BITCH to do...
 
1 - 3 of 3 Posts
Top