Dakota Durango Forum banner

1 - 8 of 8 Posts

·
Eatin' Ford Shittin Chevy
Joined
·
325 Posts
Discussion Starter #1
i have the 5.2 in my Durango. And i was plugging it in the other night so i could start it the next morning and i see this oil deposit around the spark plug shroud. so i unplug the wire and its all over it too. What does this mean? and am i going to have to fix something expensive in a quick like fashion?

all helpful answers are appreciated.
 

·
Eatin' Ford Shittin Chevy
Joined
·
325 Posts
Discussion Starter #3
the thing is, its only one cylender its doing this in. its the second one up from the back of the motor.
 

·
6.9 6 speed
Joined
·
5,421 Posts
check your valve covers, breather, breather hose and the PVC valve. Shouldnt be a big issue. Have you recently changed the oil and accidently spilt some?
 

·
Registered
Joined
·
546 Posts
last time I changed the plugs in my 5.2 I had oil on the threads of one of the passenger side back 2. don't remember which. Must be a slow leak since I don't seem to lose oil noticably.
 

·
Eatin' Ford Shittin Chevy
Joined
·
325 Posts
Discussion Starter #8
its the passenger side.

no, its not inside the cable. its ON it.

I changed the oil before it got really cold outside. so...early november ish im pretty sure. I might've spilt a little, but it wasnt on that side, and i drove it after it burned off once i ran it afterwards.

And i checked the oil. its at the bottom of the safe side. But i havent lost a considerable amount that i shouldnt worry too terribly much.
 
1 - 8 of 8 Posts
Top