Dakota Durango Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2003 V8 4.7L club cab
Replaced blower motor and resistor today and it still does not blow anything! Fuses fine. Just stopped working for some reason. Thermostat maybe? Any ideas? It seems to get a little warm but when dials turned nothing happens. Rear defroster button lights up and works. All dials are plugged in. Battery is fully charged. Any ideas? Doubt it’s the heater core but with my luck.......
 

·
Registered
Joined
·
225 Posts
Back flush your heater core. Remove both hoses on the heater core at the fire wall. Using a water hose with a sprayer force water into one core tube and then the other. Keep rotating between the tubes until the water runs clear. Reconnect the hoses and enjoy your new found heat.
 

·
Registered
Joined
·
1,500 Posts
The heater core and thermostat have nothing to do with the blower motor.

If the fan isn't blowing check for power at the blower motor to a good ground.

Check the fuse in the power distribution center under the hood.

The motor is wired hot via a separate circuit through the ignition switch. The ground side is switched. A bad ignition switch circuit can cause the blower motor to fail.
 

·
Registered
Joined
·
9 Posts
What he said. If your fan won't even turn on there's absolutely nothing a thermostat or the heater core is going to do. If your fan was running and you still weren't getting warm heat then yeah, maybe. But you need to get the fan going before you do anything else. Follow Dan's tips above. You have a bunk ground, fuse, the actual hvac controller switch panel, something. Also go ahead and just replace the fuses. Ive had fuses test good and still be the culprit. Worth the few cents just to be sure
 
1 - 5 of 5 Posts
Top