Dakota Durango Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 · (Edited)
Ok heres the deal: i bought a truck from my brother who lived in Biloxi during hurricane katrina. the truck, a 2000 dakota R/T, was flooded slightly. the water went out as quick as it came in they say, which was evident by the lower water level inside than the one that was outside the truck. inside the water reached just to the top of the door speakers. outside it came up to about the valve covers. no water got in the engine, it runs great. water was in the tranny and in the diff. i took care of everything you could think of. new complete battery cables (neg. and pos.), new starter, plug wires, dist cap, plugs, brakes, tranny flush, disassembled the diff and cleaned erythin.

My problem: The dash lights and gauges only work when the E brake pedal disengages from the ground switch under the dash. when the cluster is working the rpm gauge will go up to normal RPM and then go to zero and back again. also the odometer will blink sometimes and then display NO BUS. the other gauges work fine, except for the speedo which im sure has to do with a sensor now fried in the tranny because of the salt water. Ive never owned a mopar so im sort of doing guess work but i pulled the three plugs from what i think is the comp. under the hood by the air intake and there is no corrosion. im thinking maybe its a comp. problem? i removed the box i believe to be the comp. and was going to take it apart and i couldnt get the back of it off. how do i do this, i want to see if there is any corrosion in there. and it says that it has an approved upgrade on a sticker on the back of it, what does that mean? Please i need guages. :help:
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top