Dakota Durango Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Ok the vehicle in question is a 1998 Dodge Durango SLT with a 5.2L V8, 4wd, and ABS.

I DO NOT have an ABS light on. I have a BRAKE light on. At first i thought maybe just my e-brake switch was misadjusted so i took a look at it and checked its movement and everything appeared to work fine there.

So go on to the next day. Had the battery disconnected while doing an oil pump and got the truck back together and was running my diagnostic computer on it and i noticed the brake light was out. So i thought to myself maybe something had to be erased in the pcm. So i tried to e-brake again and when i pushed the pedal down the BRAKE light came on and when i released it the light went out. I tried this about 3 times and everything worked as it should. So i was satisfied with that for the moment.

Moved the truck around and shut it off. Went back out to start it up and the damn BRAKE light was on again! So at this point i was a bit disgruntled. The car does not need to be running for the light to be on. I only have to have the key on. So i turned the key on and off a couple times and nothing. So i went under the hood and disconnected a few connectors dealing with the ABS and what not and came back and tried again. This time when i turned the key on the light was out. So i turned it off and on a couple times and it stayed out. So i thought maybe just a dirty connection.

Came back out again a lil bit later and turn the key on and the DAMN LIGHT WAS BACK ON AGAIN! Fiddled with the whole on/off/on/off with the key and the light went out one time but then came back on the next.

So at this point im at a lost. As far as i can see the ebrake switch is working correctly. The Master Cylinder is full of fluid. I checked all the fuses and connections. And i cant get this light to go out. I mean it is intermittent which makes it that much worse but is on about 90% of the time.

Could someone enlighten me as to what the BRAKE light is associated with? Is it only for the EBRAKE? or is it also associated with the ABS or mastercylinder? I know if i pull out the 10amp fuse in the fuse box inside the car the light will go out. But i thought that was an ABS fuse and i dont have any ABS lights coming on even with the fuse out.

Someone help me please. This is the only thing left on this truck i need to fix!
 

·
Registered
Joined
·
332 Posts
Could possibly be speed sensor related since abs is incorporated with it somehow in the rear diff, does the abs light come on at all even with the key just in the run position? Both brake light and abs usually light up together.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
justme84 said:
Could possibly be speed sensor related since abs is incorporated with it somehow in the rear diff, does the abs light come on at all even with the key just in the run position? Both brake light and abs usually light up together.
When you turn the key on they both light up for the diagnostic procedure of start up so i know both bulbs are working. And then the ABS light will go out and then the BRAKE light will go out for just a split second and then come back on and stay on.

I would think if i was having a speed sensor issue it would trip an ABS or Check Engine light. I had my computer on it and i have no codes stored :-/
 

·
Registered
Joined
·
2,201 Posts
that sensor doesn't send a CEL code. But your correct about the ABS light. Is your speedo still working below 15MPH?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
rockadaous said:
that sensor doesn't send a CEL code. But your correct about the ABS light. Is your speedo still working below 15MPH?
Yeah speedo works fine as far as i can tell. Starts at 0 and as soon as i start moving it will start moving. No lag.
 
1 - 5 of 5 Posts
Top