Dakota Durango Forum banner

1 - 5 of 5 Posts
F

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I installed some Nu Image White Face Gauges like a month or two ago and my needles haven't been accurate since then. I had to take them off using the tool that Nu Image sent me, but when I installed the Speedometer needle, its about 10mph off. I can't get it perfect either. I made sure that its not on too tight and its not on too loose either. Does anyone have any advice on how to make it more accurate?

Do I need my truck off or running when I install? Or should I be driving? Thanks in advance...

-Matt
 

·
Registered
Joined
·
42 Posts
When I changed my guage face, I took the speedometer needle and put it on just to the underside of the pin. Then pushed it on. Then I lifted the needle itself, with my finger holding the rounded part, and lifted over the pin. It now sits hard against the pin. Kinda spring loaded in a way. So far, speedo seems accurate.

Hope that helps.

Shawn
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Damn blowndakrt, you have a really nice looking truck! Do you have anymore picutres of it then just that small one?
 

·
Registered
Joined
·
42 Posts
Thanks. I do have more. Give me your email addy and what else you would like to see. Cosmetic stuff or performance stuff. I wish the ghost flames would show up better on camera, but they don't. The are actually an Aztec gold flame, but in the pictures they just look a darker yellow.

Shawn
 

·
Registered
Joined
·
2,201 Posts
I had my truck running and in park. ;) make sure the needle rests on the post and you should be good to go. Do a speed check with a friend
 
1 - 5 of 5 Posts
Top