Dakota Durango Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
I can only get my HVAC to blow air through the defrost vents no matter what setting I put it on (the heat and a/c work, just only comes out the top of the dash). From my searches I have found that it is probably due to a defective mode door actuator.

Mine is a 2002 - 4.7 so I think the actuator is electronically controlled instead of vacuum.

According to the service manual, it says I need a DRB-III scan tool to make the actuator re-learn the mode door position settings if I replace it.

Does anyone know if the DRB-III scan tool/re-learn thing is actually required, or I can just throw in a new mode door actuator and hope that it fixes it?

I really hate having to go and get raped by a dealership on something like this that should be an easy do-it-yourself type fix.

Thanks in advance for any suggestions.
 

·
Banned
Joined
·
1,234 Posts
They are electrically controlled via a servo motor on the '01+ years.

You don't need a DRBIII tool to recalibrate - the HVAC controller will do that automatically for you. Turn on the car, turn the knob all the way one way, then the other, turn off the car. Should be calibrated.

 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
Thanks.

Any idea of where the best place to get a replacement actuator from? wrecker or new from dealer?
 

·
Banned
Joined
·
1,234 Posts
I'd try a junkyard...just due to the fact that they would probably only be a few dollars.

You can get to two of them through the driver side foot-well pretty easily (if you lay on your back and put your head next to the gas pedal).

They are interchangeable, so you don't have to worry about getting the same one from the wrecker.

I suppose if you are really up to it - you could swap the mode motor with the blend motor and see if the problem follows the bad motor.
 

·
Registered
Joined
·
843 Posts
Check the small vacuum line that runs through the firewall directly under the heater core hoses. If it is disconnected you will only get air through the defrost vents
 

·
Banned
Joined
·
1,234 Posts
Ok I have the same issue but now the temp doesn't work either. Could this be the control panel and not the door motors?
Are you saying that both the mode door and temp motors are in-operative?

Does the recirculate / fresh air motor work?

If two or more are out - seems like an odd coincidence. I'd check the control panel.
 

·
Registered
Joined
·
265 Posts
Yes the temp dial was working but the mode did not. It generally blows out the defroster but actually some air comes out of all the vents. Recently though it only blows cold. when I change temp to heat it stays cold. Could it just need a relearn?
 

·
The Anti-RUB
Joined
·
1,754 Posts
Yes the temp dial was working but the mode did not. It generally blows out the defroster but actually some air comes out of all the vents.
I have this same problem. If you figure it out, post back up and let us know how you fixed it and if it was simple or a PITA. Thanks...


Recently though it only blows cold. when I change temp to heat it stays cold. Could it just need a relearn?
This could be a lot of different problems. More often then not, its a clogged heater core. Search around the forum. There was a fairly simple step by step how-to back-flush your heater core this past winter. Good luck...
 

·
Registered
Joined
·
265 Posts
Thought about the heater core blockage but I lost temp control once before with it became unplugged after I had the dash off. I've rechecked the connector this time it is fully seated in the socket.
 

·
Registered
Joined
·
265 Posts
Are you saying that both the mode door and temp motors are in-operative?

Does the recirculate / fresh air motor work?

If two or more are out - seems like an odd coincidence. I'd check the control panel.
Did some checking this weekend and yes the recirc/fresh air motor does work. mode door still does not work but the temp seemed to work now. checked the heater hoses and both were hot so flow through the heater core seemed good. I think I need to have some check for body codes.
 

·
Registered
Joined
·
1 Posts
Rear Mode Door Issue

On my rear HVAC the blend door is operating properly but the actuator on the mode that flips the air between the floor and ceiling is not turning. I swapped the actuators and it still won't work so I know the actuator is fine. Is there anything else it could be besides the HVAC controller? I do seem to have power at the connector of the mode door.
 

·
Registered
Joined
·
1 Posts
Fixed

I have this same problem. If you figure it out, post back up and let us know how you fixed it and if it was simple or a PITA. Thanks...


I had the exact same problem. If you turn the dial and you hear the motor trying to move the doors, try looking at the servo motor under your driver side dash. It is attached to a small wheel with groves and the arms that control the doors are supposed to sit in these groves. Ensure that the arms that are attached to the grooves are in the correct groove. The one arm looked like it was attached to the wheel, but it came out of the groove so the wheel couldn't turn. It's an easy fix as you just have to pop the plastic arm back into the groove.

It's really hard to see and the groves are facing away from you when your looking at it so just go by feel. The arms seem like they run along the outside of the wheel so keep that in mind!

When mine messed up, I would turn the dial and hear it try to turn the motor, and because it was blocked it turned it back to avoid stripping the plastic motor gears. If you hear the motor adjust and then a second later adjust again, this is probably your issue.
 

·
Registered
Joined
·
2 Posts
I replaced the mode door on my 2000 Intrepid but it's still only blowing through the defrost and floor. I can do the scan and it moves though every position like it should, but goes back to defrost and throw a code for mode door failure. Any ideas?
 

·
Registered
Joined
·
1 Posts
2004 DODGE DAKOTA 4.7 QUAD CAB WITH AIR
Hi mine seems to just blow in to the dash when the heater is on . I hear doors moving but that all. their is nothing out of the dash ,defrost on the front window or even the dash , some air comes out the floor can any one help me
 

·
Registered
Joined
·
2 Posts
Rear Mode Door Issue

On my rear HVAC the blend door is operating properly but the actuator on the mode that flips the air between the floor and ceiling is not turning. I swapped the actuators and it still won't work so I know the actuator is fine. Is there anything else it could be besides the HVAC controller? I do seem to have power at the connector of the mode door.
 
1 - 19 of 19 Posts
Top