Dakota Durango Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey mangs and womangs, I just got a few issues I was hoping to get help with.
I'm going for my drivers test soon, and while I was out driving my truck, I noticed a funny noise whilst practicing my parallel parking. My power steering moans when I crank the steering all the way, and now when I open my hood, there's ATF+4 all over the engine bay, but I cannot find the leak. The power steering pump drains very fast. What do you think? When I top the fluid up, the power steering is fine, and does not make any noise.

I've just installed an HID kit, and it's hit and miss when they turn on, particularily the passenger side. Wtf?

I was sitting in my truck, enjoying my soundsystem, when my check gauges light came on, and my battery gauge needle was at the minimum. I turned the truck off, then restarted. It barely turned over, but then the battery gauge went back to normal, so I shut it off and started it again, then it started with ease. Is the Alternator toast?

any input would be awesome :)
 

·
Registered
Joined
·
864 Posts
No you have some wiring gremlins for that sort of issue sounds like a short somewhere.

HID kit is probably a cheaper or your getting additional voltage drop to the lights, which is common its a pretty long small wire run for the headlights, you can rewire it with a relay if you want to try and fix it give the lights power right from the battery and just use the stock wiring for the trigger on the relay, they did this in Mopar Action to good effect.

The engine bay isn't that complicated there are only 2 lines to and from the power steering pump your goign to have to look harder, or a seal busted out in your rack assuming your truck is 2wd.
 
1 - 3 of 3 Posts
Top