Dakota Durango Forum banner
1 - 8 of 8 Posts

·
Happy 4th of July!
Joined
·
5,360 Posts
I had my 97 at around 70+ MPH doing some insane offroad racing.... It was like autocross and snow mixed together... and a windy snow covered dirt road... The T case was hummin rather loudly, and I swapped out the fluid the next day... but I didn't notice any problems. the way I see it, Jeeps and Rango's have that fulltime 4x shit, they can go down the highway, why can't I drive fast in 4 Hi?
 

·
Blown and Squirted
Joined
·
2,513 Posts
Only one way to find out...

Our 5.9 Jeep Grand Cherokeer is full time AWD and has seen over 110mph....
Same thing goes for the Rango R/Ts. But if you have 2wd availible, at those speeds, your better off in 2wd anway.
 

·
Registered
Joined
·
47 Posts
I know you can shift INTO 4H at 80 miles an hour so I don't see why you can't drive faster than that in it.
 

·
Registered
Joined
·
515 Posts
A couple of years ago I was on the highway. They only had the right lane opened up. The left lane was still untouched, so I jumped out into the left and cranked it up to 75 in 4-hi. I drove that way for about 17 miles untill I jumped off my exit. I never had any problems with the truck, so it can't be to bad.

I can't stand it when people only go about 25 when their lane isn't even snow covered.
 

·
Registered
Joined
·
35 Posts
broke dads truck

i was driving to a girlfriends house about 40 min away when the roads were covered with snow and a little ice. i kept his 95 chevy 1500 in 4x4 hi and by the time i got there i didn't have 4x4 any more. i don't remember what part burnt up but i got stuck trying to get out of her driveway and couldn't get into 4x4. i noticed the light was off half way there.
my advice is be careful. the awd have a limited slip differential in the center and are made to go many many miles. 4x4 lock is not!
 

·
Banned
Joined
·
6,056 Posts
jasonsdakota said:
i don't remember what part burnt up...
Probably the front differential actuator. Common failure on GM trucks. Luckily our trucks don't have that problem as we don't have CAD (central axle disconnect). I also LOVe having a manual shift level for the transfercase... :biggthump
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top