Dakota Durango Forum banner
1 - 10 of 10 Posts
G

·
Discussion Starter · #1 ·
The check engine light came on in my 2000 R/T w/ 51000 miles with a missfire code 307. It started missing from idle to 2500 and I checked the plugs and they were fine have 2000 miles on them ,then cap and rotor was oe so I replaced them, still missed. Replaced plug wires still there. I checked the fuel system. If someone can help me it would be great! Im pulling my hair out
 

·
Registered
Joined
·
35 Posts
misfire

the misfire code is for cylinder 7. Make sure you don't have a plug wire mixed up. Other than that, I am not sure what all would cause it to misfire on that one plug.

Maybe you have two wires very close to each other an they are cross firing? Not sure.


Sorry I can't be more help.


Shawn
 
G

·
Discussion Starter · #6 ·
The truck is stock other than exhaust and roller rockers that the 1st owner installed. It seems to run fine after I run it and let it sit and run it when its still hot, Then after I go it starts breaking up.
 

·
Registered
Joined
·
1,177 Posts

·
Registered
Joined
·
6 Posts
New rockers?? There isn't a new cam in there set for a narrow/high rpm range is there??
 
G

·
Discussion Starter · #9 · (Edited)
the cam is stock and the rr have been in for at least a year and a half. I will have it scanned at work on monday I'll keep you all updated. this is the first time I posted on this fourm and the responce time is great, thank you
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top