Dakota Durango Forum banner

1 - 10 of 10 Posts

·
Banned
Joined
·
25,820 Posts
Discussion Starter #1
My fog lights no longer work. Not even the light on the headlight switch.

I checked both fuses under the hood. I swapped the black one with the radiator fan and still nothing. Anyone know what it can be?
 

·
Registered
Joined
·
1,135 Posts

·
Banned
Joined
·
25,820 Posts
Discussion Starter #3
I still have the turn signal problem too.
 

·
Banned
Joined
·
25,820 Posts
Discussion Starter #5
It's possible. I accidentally open the light switch instead of pulling the bulbs out. I put it back to gether fine, may need to try that again. I have to try reinstalling the led too. I had to bore that hole a bit to get the light to fit.
 

·
"][" {[]} {[]} ][_ 
Joined
·
17,338 Posts
There are 2 little copper pins that can break that control the fogs if you open the switch. Ask me how i know.
 

·
Banned
Joined
·
25,820 Posts
Discussion Starter #7
I know, I removed mine the first round! It is actualy a spiral S shape of copper, easily replaceable.
 

·
Banned
Joined
·
25,820 Posts
Discussion Starter #9
If it is not cold or wet tomorrow, I will rip the switch apart and look.
 

·
Banned
Joined
·
25,820 Posts
Discussion Starter #10
Problem solved. I completly dissasembled it and reasembled it. The led is also in there and working now. Not quite sure what happened as it was rebuilt the same way both times. I do notice now that if I lean the switch to the right when the fogs are on it may trigger them to go off unless you move it back. It may have always done that, not sure as I don't use them often. I was just playing around with them and found that out.
 
1 - 10 of 10 Posts
Top