Dakota Durango Forum banner
1 - 15 of 15 Posts

·
6.9 6 speed
Joined
·
4,711 Posts
Discussion Starter · #1 ·
I just relocated my iat sensor to the intake tube and now the engine light is on. Its really freaking me out, I dont want to mess anything up. Is this normal. The only thing i can think of is that there is a bad connection. I did a search and couldent find anything about the light. PLEASE HELP!
 

·
Getting Old
Joined
·
2,662 Posts
just put ur key in the ignition, turn the key to ON but not to crank the engine over, three times, like ON OFF ON OFF ON, and leave it at ON the last time, it should flash the troube code VIA the check engine light, or if it has a digital odometer, i think itll show the code on there. If it flashes it using the check engine light, itll be kinda like morse code. If its a 2 digit number, itll flash twice, pause flash four times, for 24 (thats an example). Then find out what the code is and fish the problem.
 

·
Getting Old
Joined
·
2,662 Posts
sick 660r said:
How do I decode it? Do you think its safe to drive while the light is on?
Dude, :jester: Ive been driving with my check engine light for like...almost 2 years! Im surprised it hasnt burned out yet...but i know why its on, so it doesnt bother me. And thanks Yellow for posting that link, i was gonna look for it later and post it up.
 

·
6.9 6 speed
Joined
·
4,711 Posts
Discussion Starter · #7 ·
Its a 2000 so it should work. Thanks so much, im going to check it today as soon as i get a chance.
 

·
6.9 6 speed
Joined
·
4,711 Posts
Discussion Starter · #8 ·
Just checked it and this is what I got. P0113 (M) Intake Air Temp Sensor Voltage High Intake air (charge) temperature sensor input above the maximum acceptable voltage.
 

·
6.9 6 speed
Joined
·
4,711 Posts
Discussion Starter · #12 ·
Everything is still stock because I just got the truck last monday and i read about how to relocate the IAT. I relocated it onto the tube that is before the airbox about 6 inches from the opening. Sorry everythings is still new to me.
 

·
...................
Joined
·
3,871 Posts
sick 660r said:
Everything is still stock because I just got the truck last monday and i read about how to relocate the IAT. I relocated it onto the tube that is before the airbox about 6 inches from the opening. Sorry everythings is still new to me.

6"s sounds right but ive only seen this mod on a aftermarket intakes thats the sensor is mounted in a metal or plastic tube instead of factory intake dryer exhuast hose type, so sorry cant help ya there. i do have an intake tube for $5 +shipping if ya interested. also have a cheap cone filter for free, just to get ya by until ya want a $200 CAI or cheaper if ya can find one used.
 

·
6.9 6 speed
Joined
·
4,711 Posts
Discussion Starter · #15 ·
I redid the wiring and the light went away. I also changed my sparkplugs to Autolite A3923. Thanks for all the help.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top