Dakota Durango Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Ok first of all my new glass pack sounds great and the problem i have been experencing has being doing it before i installed my glasspack. Soo here's what happens to my '98 durango 5.2 and the problem starts everytime i start it up and it acts up after i go down the road alittle ways, the problem is it looses power and it stutters even when i give her some gas but it kinda doesnt do it when i floor it, then it kicks back to normal, soo idk what it could be ??? Injectors dirty ? the fuel pump is loud when i put my ear up to the gas tank soo i'm guessing that's working fine, i havent done a fuel pressure test yet but idk could it be plugs?? I just don't know, it only does it when i first start it up and go down the road alittle ways even if i just shut it off for 10 minutes and sometimes it doesn't even do it. It doesn't have a CEL eaither. soo i'm ?????
 

·
Registered
Joined
·
141 Posts
Discussion Starter #3
are you sure?? it starts right up fine, it holds 15 volts fine never fluctuates. yesterday it did it even after starting it up, i started it up with my remote start and let it run for like 10 minutes or soo and when i was backing up she was idling like crap and stalled out it did it twice while i was trying to back up then when i put it in drive the rpms jumped up to like maybe 1500rpm and i didnt touch the gas. this morning i started it up again with the remote start and let it idle for 20-25 minutes and it didnt do anything.
 

·
Registered
Joined
·
130 Posts
How far down the road? The more info you give us the better chance we can help. Was it cold out? Moisture in the air? Even if you don't think it is important, it might be. What RPM's? What gear is it in? If it is an automatic & in drive, is it in first, second, third or OD? Good luck. Sometimes you have to wait until it gets worse before you can find it. Can you duplicate it on demand?

Toby
 

·
Registered
Joined
·
141 Posts
Discussion Starter #6
i dont think its the tranny, it may be a dirty injector. cause it doesn't happen in a curtin gear. Yes i know diagnosing it with every detail is the best way to solve stuff.
 

·
Registered
Joined
·
130 Posts
Not suggesting the tranny, just that depending on what gear can be more of a load which can cause ignition to fail. Like I said you may not feel it is important, but it might be.

Toby
 

·
Registered
Joined
·
141 Posts
Discussion Starter #8
ohh ok, well i dont really pay attention to what gear or wat rpm it is at, but i will look for it next time it happens and i will c if it does it in the same gear and around the same rpm everytime.
 

·
Registered
Joined
·
22 Posts
Was there ever a solution to this mine has started to do the same thing. Acts like its not getting any gas, and sometimes its doesn't do it at all. I replaced PCV cause I was getting the vibrating line between it and the intake. I thought that was maybe it but it still continues. One reply here was maybe the battery going bad? Any help would be greatly apprecitated. My truck is a 99 Durango with the 5.2 all stock.
 

·
Registered
Joined
·
13 Posts
Sounds like a clogged catalytic converter to me. Trying pulling the front O2 sensor and driving a ways. If the problem goes away you need a new cat.
 

·
Registered
Joined
·
2 Posts
1998 Durango Stalling

Here is what a local repair shop did to correct my Durango from Stalling. I almost got rid of the vehicle, as it seemed others could not fix the issue.

The following was replace. I have also added the cost, which included labor.
Clean Fuel Injectors and Rail ($91.30)
Tighten Loose neg Battery Terminal ($0.00)
Cleaned Throttle Body and Idle speed control value ($90.69)
Reset Minimum Idle Speed and all Adaptives, (Included in the above price)
Replaced Map Sensor ($164.00)
Upon completion of work,I was told to run the car for ~ 45 minutes or more at higher speeds to clean out some of the carbon.

The work was done in May this year and has be running great since then.

Phil....
 
1 - 11 of 11 Posts
Top