Dakota Durango Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
so our 2015 Durango Citadel AWD Hemi 8-speed is a sweet machine and has lots of power...but it has this quirky 'delay' when shifting between 1-2-3-4... - 5-6-7-8 seem smooth and firm with no delay. Doesn't matter if it's warmed up or not. Start out in 1st, goes through 1st and it literally feels like a fast manual trans shift sequence - like the transmission is dipping a clutch, shifting into 2nd, and re-engaging a clutch all over about 1-2 seconds, and the 'clutch' isn't exactly smooth either.

I'd expect a modern trans like these 8-speeds to have nice positive and nearly unperceivable shifting through the gears, but from 1-2-3 and into 4 there's this sorta jerky 'delay' - literally feels like [clutch in-shift-clutch out]. I'd love for the first half of the gears to shift just like the second half.

Tried eco mode on/off - no change. Has 46k miles so still under warranty, but what gives?

Anyone?
 

·
I hate you people.
Joined
·
2,765 Posts
These newer automatic transmissions have had teething issues when it comes to how they operate and Chrysler has had difficulties trying to get the 8spd.s and 9spd.s to shift properly like the older less geared transmissions. Your issue could be that the trans needs to be reflashed but it could also be signs of a mechanical issue. The only way to know is to take into the dealer to have the techs check it out and if there is no problems, they may go ahead and reflash the PCM to put in the newest transmission flash.
 

·
Registered
Joined
·
340 Posts
Discussion Starter #3
thanks for the info. We're going to take it in to at least have it inspected - hopefully they can determine the issue and correct it.
 
1 - 3 of 3 Posts
Top