Dakota Durango Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
i have a 99 durango and the instrument cluster is acting crazy.all of the warning lights expect check engine lights are blinking on and off and the tach,oil pressure,temp and the voltage needles are jumping up and down.i already check the battery terminals.nothing happened.now what?
 

·
Registered
Joined
·
5 Posts
Heater Core Replaced, now getting the same thing

Does anyone know what this is. I brought my D98 to PEP Boys to have the heater core replaced (since I didn't have time to do it myself) and they replaced the heater core. When I picked it up everything was fine, except for the temperature selector would not go all the way hot, something was wrong with the cable alignment or something. Next day, on my way home from work. Airbag light came on, them random dash lights came on. The all needles went to zero....few minutes later...rpms go normal... then speedo goes normal, then all dead again....

Pep boys is looking at it now. I know they had to remove the gauge cluster to do the heater core, and they have not denied anything yet...but I am trying to find info on this to be prepared if they damaged something...

Anyone who could help us out with this, would be great and appreciated!
 

·
Super Modder
Joined
·
4,368 Posts
probably just the power ribbon is not in straight. vibrated out of alignment...just reconnect the ribbon and it should be fine.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
gauges

what is the a power ribbon?where is it at on the durango?please let me know before i take it to the dealer.thanks
 

·
Registered
Joined
·
5 Posts
Thought it was fixed.

Brought it back to Pep Boys, they tried to figure out what it was. The end result was that they reinforced the 2 harnesses so that it would plug in to the back of the instrument cluster tighter. Thought this would fix the problem, but today on the way into work... same thing.... intermittent guages, and warning lights... then all off....all on....

They said that the dealer told them that they need to reprogram some chip everytime a component is added or removed, but this is a seperate issue.

All I could find on the web was the G202 ground wire needs to be checked:

http://www.v8performance.com/tipsandtricks.htm#G202

I saw a TSB for the 1999 Durango that says the harness needs to be rewired out. Symptoms are exactly what we are experiencing. Is this the power ribbon you are speaking about?

http://dodgeram.info/tsb/2000/08-05-00.htm

Thanks all for the help and input, this has been a long in and out of service issue! Please let me know if anyone has performed the above to fix their problems!

Thanks!

Steve
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
My dash gauge move up and down,nothing is working at all.i dont even know how much gas i have.i ran out of gas last week.But when i put the emergency brake down everything stop but nothing move while driving.what is the deal?i guess i will have to take it to the dealer which i am not trying to do.
 

·
Registered
Joined
·
5 Posts
Took it to the Dealer...

When Pep Boys removed the A/C housing to replace my heater core, they dumped antifreeze into the ABS unit. They cleaned the abs unit and still problems! Now, the dealer has replaced the ABS module and says all is fixed. So I guess if one unit is freaking out, it can disrupt all communications to the instrument cluster!

Good think is Pep Boys says they will reimburse for the repair since the dealer says it only happened because of the removal procedure being performed incorrectly and not the pinhole leak in the heater core.

I pick it up this afternoon!

Hope this helps! Maybe it is one of the information sending units tied to the warning lights...

If this helps, It did seem as though the ABS light came on before all others. Sometimes only a 1/2 second before, but still I noticed it.

Thanks!
 
1 - 7 of 7 Posts
Top