Dakota Durango Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
546 Posts
Discussion Starter #1
The cruise control won't turn on in my truck. The horn works and I don't have any codes or airbag light. So I doubt the clockspring is toast. Any other common causes?
 

·
Gen I FTW
Joined
·
6,010 Posts
i have the same problem as you, but i believe my cruise control setup was taken out of the truck. what does the entire assembly look like ?
 

·
Gen I FTW
Joined
·
6,010 Posts

·
Resident Craigslist Whore
Joined
·
3,230 Posts
ive never had the issue, but ive heard here and there that the cruise is operated off a vacuum canister or somethin under the wiper cowl. try that? :huh:
 

·
Registered
Joined
·
1,235 Posts
mine doesn't work either, and i can't remember if it ever has. never looked into it really cause i rarely ever use it to begin with, but it would be nice to know what the problem is if anyone figures it out.

i'm pretty sure it would have worked when i got the truck or else i would have taken it back to be fixed. i think something happened when my pcm died and i had it replaced by the dealer. this happend twice due to a bad alternator.
 

·
Registered
Joined
·
546 Posts
Discussion Starter #8
I looked around about a year ago regarding my issue. I seem to remember reading something about bad Crank position sensor causing issues with cruise. But the truck starts and runs awsome for being 13yr old. wouldn't a bad CPS cause drivability issues or something otherwise noticable?

I'll haveto look into the vacuum canister theory
 

·
Registered
Joined
·
12 Posts
Just for fun, remove the plastic casing around the column, and check all the wiring that runs down the column... I had a 99 GC that the wires broken.. Worth a check!
 

·
Registered
Joined
·
15 Posts
i noticed my cruise light lit up but wouldnt work as well. i also noticed my headlights wouldnt turn on except for my brights. all i did was readjust my tilt on the steering column and they both turned on. so i would just check for the wiring in the steering column. hope that helps
 

·
5 Door Whore #176
Joined
·
375 Posts
just an update for you guys my cruise quit working the other day light came on but wouldn't work. There is a vacuum canister behind the passenger head light next to the intake. and there is a vacuum line from the firewall across the intake manifold to there that had broken on me. I would suggest checking there first.
 

·
Registered
Joined
·
546 Posts
Discussion Starter #13
my problem is I get no light.. nothing to show that it acknowledges the input. I'm thinkin it's gotta be a wiring problem
 

·
5 Door Whore #176
Joined
·
375 Posts
I would check the actual buttons on the steering wheel with my on/off button I have to press 5 or 6 times sometimes before it turns the cruise on
 

·
Registered
Joined
·
375 Posts
I have the problem where I have the light on but no setting, Ive read it can be the sensor on top of the rear because of the problems with the abs & brake lights coming up. Im not sure, there seems to be no easy way to figure it out
 

·
Registered
Joined
·
375 Posts
TO EVERYONE WITH CRUISE CONTROL ISSUES, CHANGE YOUR BRAKE SWITCH!!!
I had my truck from May '11 to now (Feb '12) and my brake lights worked fine but my cruise control would not set. Recently I discovered I had no brake lights, I knew it was from the switch because all other rear lights (turn signals, running lights, hazzards) worked fine. (probably from me bouncing on the pedal at red lights to the beat of music) So I bought the switch off ebay, only $13, put it in today, and BOOM I HAVE CRUISE CONTROL!!!!!!!!!!!!!!
 
1 - 18 of 18 Posts
Top