Dakota Durango Forum banner
1 - 5 of 5 Posts

·
No Dak, but a Dodge!
Joined
·
428 Posts
Discussion Starter · #1 ·
So a week ago friday I drive down to play my hockey game, everything was fine. When I went to leave, I noticed the brake and ABS lights were on. It had been raining so I assumed water got into something, so thought I would keep going. When I got on the road I noticed my speedometer stopped working. Next time I get in it, the check engine light comes on. I take it into Autozone to do a check engine diagnostics, and they said it was a Speed Sensor Malfunction, so I replaced that...still same problems, took it back in, said same thing.

My speedo will bounce around at about 55MPH, then my auto door locks will kick in, then about 70MPH the speedo will work, then I can finally use my cruise, so it isn't just the speedo, it has to be something to do with the speed sensor obviously.

Now, they transmission has been going out for a long time, I am assuming that is what is going on. But if thats the case, whats the deal with the ABS and brake lights on? Or is there something else someone knows about? Thanks, sorry for the length!
 

·
Registered
Joined
·
1,177 Posts
it all ties into the speed sensor output. could it be you got a bad one? or have you tried change'n it out for a second time? or possibly the speed sensor input
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top