Dakota Durango Forum banner
1 - 9 of 9 Posts

·
hobby or addiction?
Joined
·
899 Posts
Discussion Starter · #1 ·
My truck quit charging the battery, so i ordered an alternator off the internet. It was used btw. But i put it on and its still not charging. I havent even looked at it since the day i put it on, but where is the voltage regulator, or did i just get another bad alternator? Its a 98 with a 408 btw...
 

·
Resident Craigslist Whore
Joined
·
3,230 Posts
just disconnect the alternator-to-battery wire from the alternator, start the truck, and put a fluke/multimeter on the stud and see what its puttin out for juice.
 

·
the blue blur...
Joined
·
2,436 Posts
my 03 did this once...i went through two alternators before discovering the cable that connects to the alternator had gone bad and had basically burnt up somehow at the terminal. not saying that is your problem, but cover all the bases before you buy anything else.
 

·
hobby or addiction?
Joined
·
899 Posts
Discussion Starter · #8 ·
You may also have a bad battery temp sensor in the bottom of the battery tray. :huh:

You getting any codes?
My check engine light has been on now that you mention it, i dont have any kind of scanner though.
 

·
Resident Craigslist Whore
Joined
·
3,230 Posts
My check engine light has been on now that you mention it, i dont have any kind of scanner though.
autozone or advance will do it for free. i ended up buyin one a while back, used it a ton of times on my vehicles and my buddy's vehicles.
 
1 - 9 of 9 Posts
Top