Dakota Durango Forum banner

1 - 9 of 9 Posts
W

·
Guest
Joined
·
0 Posts
Discussion Starter #1
:confused: My blower fan only works on the first 2 speeds , leaving the 3rd & 4th speed not working at all , would this problem be the fan or the speed control switch. Wade
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #5
What junk i got the same problem but mine is completly gone now. but its right in front of the duct? so easy to get too? and is the part a delar part or can i get it from autozone?
Thanks
 

·
Registered
Joined
·
1 Posts
It's a common problem

I've replace this part on a 2000 Pontiac Grand Am, a 2002 Chevy Impala, and now I need to replace it on my 2001 Dakota. I've not done it yet, but I've found some info by searching other Dakota message boards. Seems that Dodge has moved this resistor block around (it started on the firewall under the hood on the passenger side, and has migrated into the cab under the dash on the passenger side near the blower motor).

I'll post again after I've finished the job on mine.
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Confused

Wade said:
:confused: My blower fan only works on the first 2 speeds , leaving the 3rd & 4th speed not working at all , would this problem be the fan or the speed control switch. Wade
It's most likely your blower switch.
 

·
eat cheese or die!
Joined
·
663 Posts
Waydo said:
It's most likely your blower switch.
if it was the resistor your fan would only work on high.
 

·
Happy 4th of July!
Joined
·
47,199 Posts
Yup, as said above, (Almost certianly) it's the switch, The resistor is used to slow it down from MAX (4) If 1,2,& 3 wouldn't work it would be the resistor. Really sounds like a switch problem. Sometimes the switch just needs a good cleanin/lube. My A/C button was being picky, I cleaned it out really good with contact cleaner, and then gave it a good lube of dielectric grease, has worked flawlessly since (about 6-8 months ago!)
 
1 - 9 of 9 Posts
Top