Dakota Durango Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
ok, this is a bit weird. when i put the right blinker on, the passenger blinker works fine. as soon as i hit the brake, the blinker speeds up, and the right light goes out. also, the reverse light is out too. the wiring harness looks fine, and the only thing i can think of is the blinker itself. but i dont want to spend like 40 bucks to troubleshoot if somebody knows of something else that could cause this.
 

·
Registered
Joined
·
61 Posts
Make sure all the bulbs are in working order on the outside. If they aren't, the resistance in the circuit will be different from what it's supposed to be and it will cause things to not work right.
 
S

·
Guest
Joined
·
0 Posts
Go to Autozone or O'Reillys or pepboys... some place like that and get you a new blinker plug in thingy that goes in the fuse box. Sorry forgot the name of the damn thing. They aren't all that expensive and try that. If it doesn't fix the problem take it back for a refund because its something else.
 

·
Registered
Joined
·
2,201 Posts
flasher? :jester:
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
well its not the flasher.. and all the fuses and everything are fine.. this is weird. i'm just gonna bring it to my shop one of these days. i was just really set on getting this fixed before i go on a trip, but i'm leaving tomorrow and its far too cold to fool around now.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
ok well, my hands are freezing but its fixed... one of the wires from the tail light's harness wasn't connected at all. it wasn't even in the wrapping. weird....
 

·
Registered
Joined
·
53 Posts
Discussion Starter #9
well duh, that was the first thing i tried. i know there's a small leak, but the mechanic said its nothing to worry about if i get it checked every oil change.
 
1 - 9 of 9 Posts
Top