Dakota Durango Forum banner
1 - 14 of 14 Posts

·
Back in black
Joined
·
18,381 Posts
Discussion Starter · #1 ·
....so i got a new battery and since it was under warranty instead of me tooling around trying to figure out what it was i just took it to the stealer so they wouldnt say i did somthing when i was under the hood...well, they said it was my amp that was pullin all the power from my battery which i found hard to beleive because iv had a bigger stereo in my other truck for 3yrs and no problems...but anyway- what do i need to get to stop this from happening?
 

·
Back in black
Joined
·
18,381 Posts
Discussion Starter · #3 ·
thanks bro...and yea i dont know whats going on with it...but i guess they were right though cause i just unhooked everything and havent had a problem since...but yea, ill def. get a cap :biggthump
 

·
Registered
Joined
·
227 Posts
my 01 r/t did the same. i have an amp hooked up and it seems to be hard on the battery even though i have the larger alternator on it. i already killed one battery when it was under warranty but the truck would still turn on sometimes so i took to the dealership. however i hid my amp wire before taking it and they tested it and it said replace battery i got a new free one. it's only like a 500watt max amp so i really don't think i need a capacitor but the truck turns over stronger or weaker on what seems like on an individual basis but i'm not worried.
 

·
Registered
Joined
·
667 Posts
02DakRT said:
thanks bro...and yea i dont know whats going on with it...but i guess they were right though cause i just unhooked everything and havent had a problem since...but yea, ill def. get a cap :biggthump
Just so you know, DownBoi is 100% wrong...

Try a stronger battery, maybe even a deep cell as a starter. Just give it a solid charge every once in a while. A bigger alt is your best solution, but they cost a lot, how much power are you running?
 

·
Back in black
Joined
·
18,381 Posts
Discussion Starter · #6 ·
i just got a little mtx amp stuffed under my passenger seat...the dude i got it from said it was 500watts but the sticker on the back of the amp says 350 so...i think ima go with 350 :biggthump
 

·
Registered
Joined
·
667 Posts
A 350 watt amp shouldn't have that much of a pull on your battery. Just make sure you're not listening with your car off. That can definitely drain your batt very quickly, even with a small amp. I'd say just get a little nicer battery and you'll be fine :)
 

·
Getting Old
Joined
·
5,037 Posts
JohnnyKo12 said:
Just so you know, DownBoi is 100% wrong...

Try a stronger battery, maybe even a deep cell as a starter. Just give it a solid charge every once in a while. A bigger alt is your best solution, but they cost a lot, how much power are you running?
so batteries just magically die for no reason just because u have an amp? And a bigger altenator wont do anything if the battery is dieing for no reason when the truck is off...unless u also have some magical altenator that charges when the truck is off.
 

·
Registered
Joined
·
667 Posts
DownBoi said:
so batteries just magically die for no reason just because u have an amp? And a bigger altenator wont do anything if the battery is dieing for no reason when the truck is off...unless u also have some magical altenator that charges when the truck is off.
sorry I should have said 50% ;) Yes the batt won't drain when the truck is off, sorry. I meant you were wrong about the cap.
 

·
Premium Member
Joined
·
74,419 Posts
Yeah man I have two amps and my battery is doing good :biggthump and stock alternater.. I did upgrade to a Yellow top though :mullet:
 

·
Premium Member
Joined
·
74,419 Posts
02DakRT said:
i bought the truck used so maybe the battery was just shot to begin with and it finally went once i got it lol but im still kinda iffy about hookin the stereo back up...

yeah that could be it ..... It should be fine man just don't run the system with the truck off .. I never do :biggthump one song at max...


I have had system for 5 years and just your normally battery dieing .. and lots of others run systems as well.. you should be fine man .. :biggthump
 

·
Back in black
Joined
·
18,381 Posts
Discussion Starter · #14 ·
DakotaLivLrg said:
yeah that could be it ..... It should be fine man just don't run the system with the truck off .. I never do :biggthump one song at max...


I have had system for 5 years and just your normally battery dieing .. and lots of others run systems as well.. you should be fine man .. :biggthump
alright, i think im going to go ahead and hook it all back tmrw...but if the battery dies...you owe me a new one! :joke: but seriously, thanks for the input bro :biggthump
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top