Dakota Durango Forum banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
Rookie Post, so bear with me. I have a 1998 Dakota 5.2L/4x4. New problem arose: the ABS and Brake lights are on continuously, and the Rear ABS does not work (doesn't have front ABS). The Local Repair shop said its in the wiring, but it worked fine a week prior to him looking at it and I doubt the wiring change;. Is there something thats prone to failure or a way I can test the abs components? I thought the Vehicle Speed Sensor is a possible culprit as the speedometer will not read below 22mph, and I believe the Brake system (abs) gets some sort of signal from/through the VSS.. Does anyone or has anyone deal(t) with this sort of problem(s)? I appreciate any input you folks might have..

-Tim
[Befuddled dakota owner]
:help:
 

· Premium Member
Joined
·
778 Posts
This is a common problem with dodge. The culprit is the abs speed sensor located on the rear axle above the drivetrain. Its a dealer only part which is about 40 bucks and takes about 30 minutes to install. I had to replace mine about 3 months ago.
 

· Premium Member
Joined
·
778 Posts
yeah, i had the same prob...no speedo below 20mph.
 
G

·
Discussion Starter · #5 ·
much thanks

I will look into this next week. Thanks for your help.. These idiot lights are driving me nuts... :)

-Tim
 

· Registered
Joined
·
21 Posts
I had to change out my rear wheel speed sensor not too long ago because I had all the symptoms you had FlameRed98. As soon as I changed it all the idiot lights turned off and the speedometer worked normally.

Chuck Robbins
 
G

·
Discussion Starter · #7 ·
I bought my r/t with a auburn rear and 4.10 gears. My lights are on too and was told that the speed sensor wont work with the auburn/gears. Is this true or is it possible to change the sensor and fix it???? Anyone else have this combo/problem??
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top