Dakota Durango Forum banner

1 - 7 of 7 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi guys,

I dont know where to post this, so I hope this is the right place.
I have a 98 Durango with 80,000 miles. Yesterday, I was driving and all of a sudden my brake light and abs light came on at the same time. I havent gotten the chance to check my brake fluid yet (which I will do it today), but not just that, but on the freeway while driving around 60 mph, as soon as those two lights came on, my speedometer dropped to 0 mph.

Do you know why it did that?? Will adding brake fluid make the speedometer work again? My RPM's work fine, just the speedometer doesnt. Now it just sits at 0, and doesnt go up. Also both of those lights are still on.

P.S. When I turn off the engine, and come back in a couple minutes to restart the Durango, those two lights go off. But later on, will come back.


Thanks in advance guys.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #2
never mind. Got it fixed.

Turned out to be the damn rear diff. speed sensor. Cost only $32 at dealer, and 20 minute to install.
 

·
Premium Member
Joined
·
9,131 Posts
Davidle said:
never mind. Got it fixed.

Turned out to be the damn rear diff. speed sensor. Cost only $32 at dealer, and 20 minute to install.

yep that's it I need mine done sometime. If I would have found this post earlier I could have saved you some $$ on that sensor
 

·
Registered
Joined
·
6 Posts
How much can you get the sensor for ?? I need one, too...
 

·
Registered
Joined
·
6 Posts
Lowest I've found (from a dealer with discount) is $24.76
 

·
Registered
Joined
·
10 Posts
Lowest price on sensor?

Where did you find that sensor at that price as I need a new one? My speedometer doesn't function as it should, and the brake and ABS trouble lights are lit. So could you send me the place to get the sensor? It would be appreciated. Thanks Greg Stumpner.
 

·
Likes More Power!
Joined
·
282 Posts
I bought mine at Rock Auto, can't remember how much but it was a better deal than everyone else. The funny thing is that both lights were on and the speedo still worked but the cruise did not. On the parts instructions, it says this will not repair a defective speed sensor!

My lights are still on :(.
 
1 - 7 of 7 Posts
Top