Dakota Durango Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hey all,

Recently i discovered the old Durango was having some issues hard starting - would take a while to crank and when it did finally turn over the truck would run but not idle (had to keep foot on the gas). When I plugged my scanner into the OBD II port there was no related codes. I figure it's likely the idle air control valve, however wanted to see if anyone else had any other ideas before i go ahead and replace it.

Thanks
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #2 ·
IAV got some condensation in it, with the super cold weather here the valve froze. Got a new one just in case but it works fine now.
 

·
C'mon Dodge - NEW DAKOTA
2003 Dakota Club Cab Sport 4.7L
Joined
·
594 Posts
IAV got some condensation in it, with the super cold weather here the valve froze. Got a new one just in case but it works fine now.
Thanks for following up with that. Too often people don't post their findings.
 
  • Like
Reactions: IanDurango98

·
Registered
Joined
·
1 Posts
Hey all,

Recently i discovered the old Durango was having some issues hard starting - would take a while to crank and when it did finally turn over the truck would run but not idle (had to keep foot on the gas). When I plugged my scanner into the OBD II port there was no related codes. I figure it's likely the idle air control valve, however wanted to see if anyone else had any other ideas before i go ahead and replace it.

Thanks
Check your fuel pressure,
 
1 - 4 of 4 Posts
Top