Dakota Durango Forum banner

41 - 53 of 53 Posts

·
Registered
Joined
·
399 Posts
Discussion Starter #41
again back on topic...for the performance tune on the superchips 3715, do you have to use 91 octane?
 

·
Registered
Joined
·
1,236 Posts
again back on topic...for the performance tune on the superchips 3715, do you have to use 91 octane?
yes you have to or you will have a risk of pinging, especially if you have other A/F mods done. i tried using 89 on the towing setting one time and it was bad news. i had forgotten that this setting also required high octane and wanted to save some money for my trip but it was pinging under load the whole way. i had to really regulate the throttle so i wouldn't blow the engine.
 

·
Registered
Joined
·
126 Posts
I had the Superchips 3715 on my 4.7 automatic before I got the SCT tuner and it shifted a lot better with Superchips. The shifts were much firmer. The engine performance is way better with SCT, but the shifts are nowhere near as quick and firm as with Superchips. I think if the shifting could be improved with SCT it would be worth another couple tenths in the quarter mile.
 

·
Registered
Joined
·
96 Posts
with the 3815 i know the newer models are able to alter where it shifts on the 1-2 wot and 2-3 wot. Why did they not make that available for the other years? I got an 03 with the same goodies as the newer models. Just doesnt make any sense
 

·
Registered
Joined
·
335 Posts
with the 3815 i know the newer models are able to alter where it shifts on the 1-2 wot and 2-3 wot. Why did they not make that available for the other years? I got an 03 with the same goodies as the newer models. Just doesnt make any sense
I think there is somthing diff about the tcm. Compined with the pcm...or somthing...i forget but thats the general idea.
 

·
Black'd the F**k out....
Joined
·
210 Posts
Got my 3715 today and happened to be perfect timing that I needed to fill up with gas....so I filled up with 93 octane, threw in the "Performance" tune from the 3715 and took the Durango out for a spin...

The most noticeable thing right off the bat was how much differently the truck shifts now...

I'm gonna pretty much try testing out the different tunes for different reasons and I'll post up my findings for you guys...

Josh
 

·
Recovering [email protected]# thanks AA
Joined
·
582 Posts
again back on topic...for the performance tune on the superchips 3715, do you have to use 91 octane?
Only for performance, and tow mode. The only difference between the two is shifting. The 87 octane mode is much better than running stock tuning, and still use low octane fuel.
 

·
Registered
Joined
·
96 Posts
I already have the superchips Performance mode installed. Question is, do you think I can get away if I add the jetchip stage II back on there so they could work together? anyone here try this?
 

·
Registered
Joined
·
335 Posts
im pretty sure i read they conflict. also for anyone getting the tuner from superchips the new one is 3865. it's tricky to run, read my no buss post.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #50
alright guys. my battery died yesterday. after letting it run for a while I plugged in my superchips (to make sure I didn't lose the tune) with the truck off. I followed the directions on the superchips and when I turned the truck ON but not STARTED it read "no bus" on the odo and none of the gages worked. also had a CEL. i started the truck up and it ran fine, gauges worked, no CEL. so it only happened when the truck was ON but not started. no DTCs. thoughts?

sorry for the long post i'm pretty confused here. I did a search already to no avail.
 

·
Registered
Joined
·
335 Posts
alright guys. my battery died yesterday. after letting it run for a while I plugged in my superchips (to make sure I didn't lose the tune) with the truck off. I followed the directions on the superchips and when I turned the truck ON but not STARTED it read "no bus" on the odo and none of the gages worked. also had a CEL. i started the truck up and it ran fine, gauges worked, no CEL. so it only happened when the truck was ON but not started. no DTCs. thoughts?

sorry for the long post i'm pretty confused here. I did a search already to no avail.
Are you turning it to ON or to RUN. When it is turned to ON, the only thing lit up on the dash is the gear selector. No radio, guages, 2wd/4x4 selector...nothing. When it is turned to RUN...the position right before cranking...it will not work as the PCM is still communicating with the info cluster of the guages etc. This is an issue that I have very recently had experience with on the 3865 that I have informed superchips about.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #52
yeah i am turning it to the posistion right before cranking, whatever that may be called :funny:
 
41 - 53 of 53 Posts
Top