Dakota Durango Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Well my wife finally wants me to get her Durango fixed. I need some help figuring a few issues out first.

#1. A/C doesnt always blow cold air. Started on the rear system, now its doing it on the front system. Ive seen some posts about the Blend door issues. Im 99.9% sure this is my issue. Would you replace the blend doors with stock or Heater Treater doors. I only saw Dodge Ram listed on their website. Will those work for the durango? How about the actuators? Should they be replaced? Also is there anything else I should replace while I have the plenum box out. I never ever want to do that twice.


#2. There is a small intermittent leak under the front center of the vehicle. If i park it for several days, there's a 2 inch wide puddle of red/pink clear fluid of some sort. My guess is Power steering fluid, just want some thoughts on trouble shooting that.

#3 The Body mount under the passengers floorboard area is bad. The mechanic wants to replace them all. What do yall think? Should I replace just the rubber or all the components of every mount or just the broken mount rubber pieces?

All total, the mechanic wants about 2500 bucks to fix all this. Im thinking thats a awful lot of cash. Ive taken dash boards out before in my bronco. the durango looks similarly a pain in the ass, but doable. THe body mounts though, require to lift the vehicle and im not up to working underneath it.
 

·
Registered
Joined
·
23 Posts
I'm never on here, and don't know a lot but maybe I can help. And yes, there isn't a whole lot of traffic on this forum

1- is any air coming out? Does is adjust correctly when you change the settings I.e. floor, defrost,etc. If that seems to work, then it's not your blend doors. I had ac issues, and my system had a leak in it. They put some dye in the system, located the leak when I went back later and replaced the connection where the leak was. Refilled the freon, and on I went. Cold ever since.

2- likely a transmission hose leak. I have one on the hose connection to my cooler right now, but because the tranny fluid is old, it's more brownish then pink (pink is new fluid). I don't think it's power steering because I don't think it's pink, or likely to leak where you are talking

3- bad body mount? Def. don't need to replace all of them.

Good luck! I'm poking around on here for numerous general maintenance things I have to do with my truck.
 
1 - 3 of 3 Posts
Top