Dakota Durango Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys,

I'm new to the forum and have been searching for some info on diagnosing or fixing my problem.

My driver side headlight doesnt work. even the High beam. I have replaced the bulbs with new ones.
I'm looking for a fuse that might be blown, but I couldn't find them.

My Interior fuse box doesnt have the cover anymore, so I'm not sure which one to use.
I've searched for the diagram but they seemed wrong as well. Any help would be great.
Thanks!
 

·
Registered
Joined
·
300 Posts
Hi guys,

I'm new to the forum and have been searching for some info on diagnosing or fixing my problem.

My driver side headlight doesnt work. even the High beam. I have replaced the bulbs with new ones.
I'm looking for a fuse that might be blown, but I couldn't find them.

My Interior fuse box doesnt have the cover anymore, so I'm not sure which one to use.
I've searched for the diagram but they seemed wrong as well. Any help would be great.
Thanks!
If its only one side and both your low and hi beams do not work I would check the connector first. I would think a blown fuse would take out both sides, not just one half. I own a 98 so things may be differeent. If you have a meter check to see if you have power to the light via the connector. But first pop the connector off and see if you have any visual discrepancies.
 

·
Registered
Joined
·
4 Posts
What year and model is this vehicle? Has it been in a wreck? I do agree that checking voltage
at connector is where I would start. With year, make and model more info. is available.
 

·
Registered
02 4.7l Dakota
Joined
·
143 Posts
What year and model is this vehicle? Has it been in a wreck? I do agree that checking voltage
at connector is where I would start. With year, make and model more info. is available.
Says right in the title, 04 Durango
 

·
C'mon Dodge - NEW DAKOTA
2003 Dakota Club Cab Sport 4.7L
Joined
·
297 Posts
Hi guys,

I'm new to the forum and have been searching for some info on diagnosing or fixing my problem.

My driver side headlight doesnt work. even the High beam. I have replaced the bulbs with new ones.
I'm looking for a fuse that might be blown, but I couldn't find them.

My Interior fuse box doesnt have the cover anymore, so I'm not sure which one to use.
I've searched for the diagram but they seemed wrong as well. Any help would be great.
Thanks!
If it's only the drivers side, it's not likely a fuse. I've never seen headlights divided between two fuses.

More than likely you've lost the ground connection to that bulb socket.
 
1 - 5 of 5 Posts
Top