Dakota Durango Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My Durango (2001 - 4.7L - 122K miles) had the front fan blower quit working. I did once already (a few years ago) replace the fan resistor with the upgraded style. I went to change the resistor and can not get it unplugged.......it looks to have somewhat melted and 2 of the wires had the insulation melted a bit (but no blown fuse). I pulled the fan and replaced that..........mainly since it was little stiff to turn, but it fell off of the bench and broke the squirel cage. I will now be going to get a new plug and connectors so I can fix the plug that goes into the resistor.

Any thoughts and suggestions? Should I look to the switch as a culprit?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Although I started this, I guess I am X3!!

I did change the resistor ($12.00), blower ($75.00) and got the resistor harness ($75.00) installed and all works. I will fell better after a few weeks. My good friend (an electrical engineer for Delphi (GM)) helped me (did most of it) installing the harness. He cut back the wires and soldered in the connections and heat shrunk them. Looks better than new. Anyway, he commented that this is really something that should be a recall issue for Dodge, but since there were no fires or occupant hazard that that would not happen. I am not complaining about my Durango (it has been great), just want to share thoughts and comments.

It was also interesting that the local Dodge dealer commented that they were out of these harnesses and have been "selling them like crazy"! Also, another dealer said that there were 3 upgrades to this harness repair kit and the price went from $19 > $75.
 
1 - 2 of 2 Posts
Top