Dakota Durango Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Well, it's doing it again.

Gauge shows high charge cycle....then goes to normal....then back to high charge. Tried the suggested running of a redundant ground from the alternator to th PCM. Didn't help I don't think.

When it does go to the high charge cycle, if I try to turn the volume up on the radio (using the steering wheel control), the volume goes down.

Also, during the high charge cycle, I'm seeing the instrument lights for the odometer and drive selector display flicker.

Had the alternator tested and it checked good, so is this all an electrical harness type problem or what?
 

·
I drive with two feet
Joined
·
1,624 Posts
Have you had your battery checked? When I had a bad/dead battery in my Durango this is what happened for me. Could be this simple. Check it before you start digging into the alternator and PCM...
 

·
Registered
Joined
·
1,235 Posts
who checked it good, and was this check on or off the truck? it's more accurate to take it off and bring it to autozone or somewhere with a bench tester.

even with that it could still be bad. i had a similar experience with an alt that tested good, but fried my PCM twice. the regulator is controlled by the PCM on the 4.7 and can be damaged by a bad alt which requires you to replace the PCM. nothing else is affected but your alt will not charge the batt. if the guages and lights are flickering and you are getting the overcharge then it's def either the alt, PCM or both. i would replace the alt first before you do blow out the PCM or damage the batt.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Battery checked good....on the vehicle. Guy said it's either Alt or Regulator function of the PCM--system is over charging. So I'll check the alternator output and hope that is it.

Any tips on the alt testing. AutoZone guy gave me a print out on how to check for a "no charge condition"....figure I'll know the alt is faulty if I don't get a steady output or higher than 14??

Thanks guys.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
I'm just gonna break out the multimeter....I'm kinda out in the middle of nowhere and only the one car. Wish I could take it in for testing off the vehicle....
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top