Dakota Durango Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have 5.9 2000 D 4x4 97K Miles
I noticed a vibration going down the rd at 50mph, I pulled up to a red light the D about died I started to take off and the D had no power and the mil light started flashing once I got up to about 45mph the mil light went out and I took the D home and parked it.
Next day I pulled code CYL3 misfire from the odometer and an OBDII tester. I changed cap, button, plugs and wires cleared the error code then tried to restart it, it started and sounded rough and back fired a little bit so I got out checked all connections and noticed I had #4 and #8 wires crossed fixed those and restarted it. I noticed it missing still and the mil light came back on. I ran OBDII and it came back error P0205 (Injector circuit open on CYL5) I then got out looked over every thing under the hood that I had been close to all seemed ok. I reset PCM and tried to restart after idling a min or two the mil light came back on this time it said P0205 and P0206 (Injector circuit open on 5 and 6).

Today I pulled the fuel rail off and moved injector 5 and 6 to a different location on the fuel rail I also reset the PCM after a minute of idling it popped the P0205 I looked over every thing then it popped P0206. I tested the injectors they are clicking and since I moved them, I can only assume they work. I also tested the connector that hooks to the injector with a test light and a multi meter. Every thing is getting fire the plugs, injectors ect ect. I have run out of any and all ideas.
Could it be vacuum, PCM, water in the gas I am at a loss
Thanks In advance
 
1 - 1 of 1 Posts
Top