Dakota Durango Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Have a 2005 dodge dakota, 4.7 HO. Truck has around 151,000 miles. Just changed the plugs and ignition coils a few months back. Just had a fuel injector replaced by a shop. When I am driving it shifts fine, runs a bit rough at idle not bad though. Runs really rough whenever whenever i get on the gas then when i try to go past 2500 rpms it just starts like jolting and kicking back almost. It just started doing this. Ran codes and they are

o2 sensors
0058
0052
p0300 multiple misfire
p0306 misfire on cyclinder 6
p2317 igntion coil 6 secondar circuit insufficient ionization.
 

·
C'mon Dodge - NEW DAKOTA
2003 Dakota Club Cab Sport 4.7L
Joined
·
485 Posts
Seems like you need to go back to that shop.
 

·
Registered
Joined
·
600 Posts
A few thoughts.
Electrical grounds.
Swap the coil from 6 to another cylinder and see if the code moves to the other cylinder.
Were the replacement coils OEM parts?

Also, what cylinder did the new injector get installed in?
 

·
Registered
Joined
·
436 Posts
Also, what plugs did you install?

These engines like good old fashioned copper plugs. Anything fancy and it will cause all sorts of issues.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
A few thoughts.
Electrical grounds.
Swap the coil from 6 to another cylinder and see if the code moves to the other cylinder.
Were the replacement coils OEM parts?

Also, what cylinder did the new injector get installed in?
The new injector was cyclinder 2. Will try and swap it i believe parts were from mopar
 
1 - 6 of 6 Posts
Top