First Dodge - Dakota Durango Forum
5.2L/5.9L/6.7L Engines Questions regarding the 5.2L/5.9L/6.7L V8 Engines

 
Thread Tools Rate Thread Display Modes
post #1 of 3 Old 08-13-2019, 04:45 AM Thread Starter
Ksoutherns
Registered User
 
Join Date: Aug 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
First Dodge

I was given a 03 Durango SLT with the 5.9. It has 199980 miles and I drive it fairly regular. So far I have replaced the following. Plugs, plug wires, cap and button, AC compressor, idler pulley and tensioner, front heater core, both front wheel bearings, all new rotors and pads, flushed the radiator and recently replaced the fuel pump. When I first replaced the plugs, wires and cap I also added seafoam to the gas and oil as well as a can of seafoam throttle body cleaner. It ran great for a few hours then started missing, running ruff or not running if the gas pedal wasn't engaged. This eventually cleared up and it ran ok till the fuel pump went out. After the tune up it has never seemed to idle right upon cold start or if it's been sitting for awhile. Sometimes after sitting upon strat up I get a rich smelling white puff of smoke from the exhaust. Also when I replaced the plugs, the old ones had alot of what looked like corrosion to me.

I would like to get it as mechanically sound as I can on my budget right now. Is it worth the money? I seem to find mixed opinions about the 5.9. Is the 5.9 a good motor? I also bought a 03 Durango specific service manual, DN 81-37003058. Amy help on what I need to start focusing would be greatly appreciated short of a engine rebuild. I actually like the car and would like to rebuild the motor in the future. For now I want to do what I can to make to the engine rebuild.

Started using Castrol 10w30 high milage oil with Mopar filter. Put in Platinum Champion plugs. However I read somewhere that Platinum plugs shouldn't be used in my 5.9. Is this accurate?

I feel like my post is information overload and would like to thank everyone in advance for taking time to read and respond.
Ksoutherns is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-16-2019, 02:33 AM
Primus
I hate you people.
 
Primus's Avatar
 
Join Date: Apr 2009
Location: Overland Park, Kansas
Vehicle: 2003 Dodge Dakota
Posts: 2,744
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
 
No, this is just what we want to see if you are having problems with the vehicle.
As for you drivebility issues, I would take the throttle body off and check the TPS and IAC. The symptoms you explained are similar to what my 94 5.2 Dakota did when the IAC went bad. Just spraying TB cleaner with the TB on the engine doesn't work on the IAC. You have to take the IAC out and clean it by hand as the carbon and dirt deposits tend to stick inside the IAC orifice. When cleaning, use an old toothbrush as any sort of metal brushes will damage the orifice and the pintle in the bottom of the IAC orifice.
Depending on what fuel pump you got, it's not unusual for certain auto parts stores brands to fail prematurely. Most of those off brands are Chinese cheap cost products and the quality on those is constantly bad. I don't remember what brand is the preferred on here but I would try to get the one that Chrysler used when these trucks were built. I say that because I still have my factory fuel pump in my 03 Dakota and have not had any signs of needing to replace it yet.
The mixed opinions on the 5.9 is because of it's fuel consumption and the intake plenum gasket are constant gripes. The 5.9 is a torque beast and with a few mods, you can see over 350 ft-lbs. for not a lot of money. Just don't expect more than 18 mpg on the highway and if you do a lot of city driving, don't be surprised to see close to 10 mpg. The one thing you need to look out for is the transmission, as that is the biggest gripe with any 5.9 owner on here due to design flaws in the transmission. Be prepared to rebuild the trans one or two times over the course of 5-7 years of ownership.
I would use whatever plug you want. I had no problems running platinum plugs in my 5.2.

Something stinks and it ain't me.
327K+ miles, mostly all original factory parts, and 15 yrs. of reliable service.....you are missed.
Primus is offline  
post #3 of 3 Old 08-16-2019, 10:33 PM Thread Starter
Ksoutherns
Registered User
 
Join Date: Aug 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Just wanted to say thank you again. Im going to do everything tomorrow and will let you know the results.
Ksoutherns is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dakota Durango Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome