turn signals dont work - Dodge Durango Forum and Dodge Dakota Forums
Register Home Forum Extras Website Features Timeslips Calendar Garage Auto Loans Search Today's Posts Mark Forums Read

Troubleshooter's Forum A place to ask technical questions.

Dakota-Durango.com is the premier Dodge Dakota Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-08-2008, 08:52 PM
kka916 kka916 is offline
Registered User
 
Join Date: Nov 2008
Location: york,pa
Vehicle: 1999, dodge, durango
Posts: 4
Reputation: 10 kka916 is just getting started
turn signals dont work

i have a 99 durango, a few weeks ago my turn signals would cut in and out, they would work for about 4 clicks, then stop. at times they wouldnt work at all, then they would cut in again..... at this point in time they will not come on at all, ive checked all fuses and relays (swapping relays) still i get nothing at all. when i turn the signals on tho i get 1 click noise thats comes out where the relay/fuses are underneath the dash. but it does not flash or continue clicking.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-08-2008, 09:29 PM
Dakudaman's Avatar
Dakudaman Dakudaman is offline
Big mouth heavy foot

 
Join Date: Jan 2005
Location: Wiesbaden, Germany
Vehicle: '98 Dakota R/T CC
Posts: 4,734
Reputation: 37 Dakudaman must have done something right
Sounds like the multi-fuckup switch!
__________________
April '08 TOTM
The BLUE BEAST!SOLD
Reply With Quote Quick reply to this message
  #3  
Old 11-08-2008, 09:49 PM
Neil's Avatar
Neil Neil is offline
Registered User
 
Join Date: Aug 2004
Location: Marlton, NJ
Vehicle: 99 Durango
Posts: 2,696
Reputation: 24 Neil is just getting started
Did you ghange the flasher relay on ht back of the fuse panel? That's the part that usually goes.
__________________
99 Durango 5.9, FT 4x4, IP stage III w/ K&N air hat, M1, SCT, Fastman TB, 1.7 RR, JBA headers, Borla cat back, Martin Saine valve body, Hotchkis swaybars, Blistein shocks, lowered 2" Black Rhino Kenya wheels, 246. 7 RWHP, 319 TQ
Reply With Quote Quick reply to this message
  #4  
Old 11-08-2008, 10:57 PM
kka916 kka916 is offline
Registered User
 
Join Date: Nov 2008
Location: york,pa
Vehicle: 1999, dodge, durango
Posts: 4
Reputation: 10 kka916 is just getting started
ok i found 1 relay that was bright green, my 4ways worked even tho my turns didnt, i pulled the green one out now...i get nothing at all no turn/4ways or clicks..my question now is...are the turns and 4ways on that relay? and could part of it go out that would make my 4ways still work and not my turns (on that same relay)
Reply With Quote Quick reply to this message
  #5  
Old 11-08-2008, 11:08 PM
kka916 kka916 is offline
Registered User
 
Join Date: Nov 2008
Location: york,pa
Vehicle: 1999, dodge, durango
Posts: 4
Reputation: 10 kka916 is just getting started
Quote:
Originally Posted by kka916 View Post
i have a 99 durango, a few weeks ago my turn signals would cut in and out, they would work for about 4 clicks, then stop. at times they wouldnt work at all, then they would cut in again..... at this point in time they will not come on at all, ive checked all fuses and relays (swapping relays) still i get nothing at all. when i turn the signals on tho i get 1 click noise thats comes out where the relay/fuses are underneath the dash. but it does not flash or continue clicking.
i also forgot to mention that my 4ways still work
Reply With Quote Quick reply to this message
  #6  
Old 11-08-2008, 11:49 PM
bwdakrt
Guest
 
Posts: n/a
Quote:
Originally Posted by kka916 View Post
ok i found 1 relay that was bright green, my 4ways worked even tho my turns didnt, i pulled the green one out now...i get nothing at all no turn/4ways or clicks..my question now is...are the turns and 4ways on that relay? and could part of it go out that would make my 4ways still work and not my turns (on that same relay)
The answer to your question is yes. Try replacing the flasher.
Reply With Quote Quick reply to this message
  #7  
Old 11-09-2008, 01:21 AM
Little Blue Guy's Avatar
Little Blue Guy Little Blue Guy is offline
#19 ƃop ǝnןq ǝןʇʇıן

 
Join Date: Jan 2006
Location: Not Sure
Vehicle: '94 Dodge Dakota Sport
Posts: 13,029
Reputation: 582 Little Blue Guy is getting up thereLittle Blue Guy is getting up thereLittle Blue Guy is getting up thereLittle Blue Guy is getting up thereLittle Blue Guy is getting up thereLittle Blue Guy is getting up there
Yea...the turn signal flasher would be the first thing I would check & replace
__________________
All our cars are here --> http://www.hubgarage.com/mygarage/A383Wing

Reply With Quote Quick reply to this message
  #8  
Old 11-09-2008, 06:05 AM
kka916 kka916 is offline
Registered User
 
Join Date: Nov 2008
Location: york,pa
Vehicle: 1999, dodge, durango
Posts: 4
Reputation: 10 kka916 is just getting started
thank you guys for all your help, ill try that monday and see if it will fix it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Durango Forum and Dodge Dakota Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:37 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright 2001-2010 Dakota-Durango Archive