P0320 No Crank Reference Signal at PCM - Dakota Durango Forum
Troubleshooter's Forum A place to ask technical questions.

 
Thread Tools Rate Thread Display Modes
post #1 of 5 Old 09-12-2008, 11:02 PM Thread Starter
txndak4x4
Registered User
 
txndak4x4's Avatar
 
Join Date: Dec 2007
Location: Lubbuck, Tx
Vehicle: 2001 Dakota CC 4.7L 4x4
Modifications: Superchips 3715, Cold Air Intake
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
P0320 No Crank Reference Signal at PCM

My truck threw a P0320 today while driving it, now its drving horrible. Where is this sonsor located and is it something i can fix on my own? I have a 4.7 by the way. Thanks guys

______________
-Superchips 3715 -UWS Toolbox
-Cold Air Intake -T/B Lift
-Flow 40 Dumped -265/75R16
General Grabber AT2's
txndak4x4 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-13-2008, 02:00 AM
Ranger50
Just a poor shlep......
 
Join Date: Feb 2007
Location: Eastern Kentucky
Vehicle: 95 Dakota Sport 3.9/2wd
Posts: 625
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Check the camshaft position sensor and related wiring first. That sensor has a nasty habit of screwing everything up. It shares power and ground with the crankshaft postition sensor. Only the signal return wire is seperate. Even when the PCM doesn't need the CMP, it can "steal" the power and ground from the CKP and throw this light.

If all that checks out, most likely the CKP is junk, replace it.

Brian

95 Dakota Sport

"Never trust an intelligent man with no money to play fair."
Ranger50 is offline  
post #3 of 5 Old 09-14-2008, 05:41 AM Thread Starter
txndak4x4
Registered User
 
txndak4x4's Avatar
 
Join Date: Dec 2007
Location: Lubbuck, Tx
Vehicle: 2001 Dakota CC 4.7L 4x4
Modifications: Superchips 3715, Cold Air Intake
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ok i looked over everything and everything checked out, now im in the process of replacing the CKP, but i cant for the life of me get it out. It will twist but will not pull out, how in the world does this thing come out? is their a special way to go about it or what? And also now im getting a P1682 and a P0700, wth?

______________
-Superchips 3715 -UWS Toolbox
-Cold Air Intake -T/B Lift
-Flow 40 Dumped -265/75R16
General Grabber AT2's

Last edited by txndak4x4; 09-14-2008 at 06:28 AM.
txndak4x4 is offline  
post #4 of 5 Old 09-14-2008, 07:26 AM
azdurango
Benz Tech
 
azdurango's Avatar
 
Join Date: Feb 2008
Location: Phoenix, Arizona
Vehicle: 2001 Durango SLT+
Posts: 889
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
There is an o-ring seal on it so you may need to pry on it to get it out. The other codes are related to the crank problem, the computer went into limp mode. Once you replace the crank sensor and erase the codes you'll be fine.

5 DOOR WHORE # 110
Performance mods: SCT tuned, H.O. cams, 2008 intake, Fastman 70mm TB, k&n intake, transgo shiftkit, magnaflow exhaust, JBA headers, 180 t-stat, Jeep GC e-fan
Exterior mods: Winch bumper made by toy4whatever, xrc10k winch, T/S lift, 3 inch body lift, pro comp 1069 wheels, goodyear duratrac 33x12.50x15, billet fuel door
Interior mods: Gen III viper seats, Blackcat gauges, RB1 nav, AEM wideband
azdurango is offline  
post #5 of 5 Old 09-14-2008, 07:34 AM Thread Starter
txndak4x4
Registered User
 
txndak4x4's Avatar
 
Join Date: Dec 2007
Location: Lubbuck, Tx
Vehicle: 2001 Dakota CC 4.7L 4x4
Modifications: Superchips 3715, Cold Air Intake
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Ok well that makes me feel better knowing its just a limp mode, i have tried everything i can to get it out, it will pull out about 2 mm then feel like there is something catching it. I've also managed to break off the the tab that the bolts onto the block by trying to pry it out.... the location of this thing sucks, can hardly get my arm in their much less get a good angle on it. Well at least i how ill be spending my day tom.

______________
-Superchips 3715 -UWS Toolbox
-Cold Air Intake -T/B Lift
-Flow 40 Dumped -265/75R16
General Grabber AT2's
txndak4x4 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dakota Durango Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome