Impala throttle 'jump" [Archive] - Dakota Durango Forum

: Impala throttle 'jump"


domay11
03-14-2010, 10:37 PM
My mom has a 2005 Impala 3.8 and every now and then, maybe once a month, she will be stopped at a stop light, and when it turns green she hits the gas, and the for a second or two nothing will happen, then it's almost as if the car says, oh shit time to go, then jump forward and goes. Any thoughts? Sorry, it's not a dodge, but I figure somebody on here might know something about this.

Something else it does is make a "zing" noise when you turn the wheel. It is coming from inside, and almost sounds like the leather on the back of the wheel is squeaking against the steering column.

vortmax
03-14-2010, 11:33 PM
Any cel's? How does it drive otherwise? Any stumbling or issues with off idle acceleration while moving ?

jrp1588
03-15-2010, 01:22 AM
Sounds like what my old mazda 626 did. In my case it was the tranny slipping. It only did it every now and then, and started slowly doing it more often till it was undriveable. Check the transmission fluid.

domay11
03-15-2010, 04:27 PM
No CEL, other wise it drives great.

Checked TF - all was good. :huh:

bwdakrt
03-15-2010, 04:33 PM
Not too familiar with the Chevy's, but does this one have the throttle cable or drive by wire?

99Dakota
03-15-2010, 04:45 PM
05 3.8 im pretty sure still has cable throttle. any stored codes? kinda sounds like its having a hiccup. GM's do weird shit with a dirty MAF sensor. i know leaving a light in my dads grand am 3.4 once in a great while it would act like it stalled quick when leaving and come back. after putting in a new MAF sensor i havent seen it do it since. I ruled out coil packs, igntion module, did a tune up changed fuel filter. ended up running alot better with new MAF, for having 170,000mi runs pretty damn good still.

hows many miles? does it have a K&N drop in?

99Dakota
03-15-2010, 04:47 PM
as far as the zing noise, its basically exactly what are u describing is happening. sometimes you can shut it up my moving the tilt wheel around a few times. comes and goes on my dads grand am also.

domay11
03-15-2010, 06:38 PM
So would cleaning the MAF do anything or do I get a new one?

When I looked behind the steering wheel it looked like there was a considerable gap between the wheel and column though. I'll check again later.

Jecht
03-15-2010, 07:07 PM
as far as the rubbing sound on the stearing wheel to the collum my wifes 00 malibu does the same thing every sence we got it almost 10 years ago.


now tye other problem. when it sits there does the rpm go up when the gas petal is pressed then goes? or the engine stays idle as pedal is pressed down then jumps. I will say 1 check throttle cable gor being loose. 2 clean tb. 3 replace the TPS as it sounds like a bad sensor.


when the car shoots off the line does the tranny hit hard or is it like when you floor a vehicle? this is why I hate shittys I mean chevys lol


I hope this helps.

be careful cleaning that maf sensor that lil wire can break easy and it cost a lot to replace

96BlkDak
03-15-2010, 07:35 PM
it has the fly by wire throttle my 2000 impala did not have a throttle cable so I doubt your moms does.

slammedR/T
03-16-2010, 02:44 AM
My mom has a 2005 Impala 3.8 and every now and then, maybe once a month, she will be stopped at a stop light, and when it turns green she hits the gas, and the for a second or two nothing will happen, then it's almost as if the car says, oh shit time to go, then jump forward and goes. Any thoughts? Sorry, it's not a dodge, but I figure somebody on here might know something about this.

Something else it does is make a "zing" noise when you turn the wheel. It is coming from inside, and almost sounds like the leather on the back of the wheel is squeaking against the steering column.

Clean the MAF sensor it is dirty,becareful not touch the wires.Just get some carb cleaner,spray the three little wires,spray off with brake clean,put back on and go.

That year prolly has the two T15 tamper proof torx, autozone should have them,they will have a small hole in the center of the torx bit,also that MAF cleaner they sell sucks balls,use carb cleaner.

DEPUTY

domay11
03-16-2010, 02:48 AM
now tye other problem. when it sits there does the rpm go up when the gas petal is pressed then goes? or the engine stays idle as pedal is pressed down then jumps. I will say 1 check throttle cable gor being loose. 2 clean tb. 3 replace the TPS as it sounds like a bad sensor.

when the car shoots off the line does the tranny hit hard or is it like when you floor a vehicle? this is why I hate shittys I mean chevys lol


1) When it sits the engine stays idle.
2) It hits hard. Not neck braking hard, but enough to go, "wtf?"

Thanks, I'll take a look at the MAF this weekend, then maybe even clean or replace the TPS if necessary.

atvrider07
03-16-2010, 04:44 AM
it's drive by wire im sure. my moms 02 bonneville doesn't have a throttle cable and does the same thing. actually the gas pedal will stick and u have to press hard on it to free it up making the car take off quick. maybe that's what yours is doing too

slammedR/T
03-16-2010, 04:51 AM
it's drive by wire im sure. my moms 02 bonneville doesn't have a throttle cable and does the same thing. actually the gas pedal will stick and u have to press hard on it to free it up making the car take off quick. maybe that's what yours is doing too

On gm vehicles that have throttle cables the TB gets dirty and will stick causeing you to press hard to move the throttle blade,you just clean the throttle blade problem solved.Also 02 will be cable not drive by wire that didn't start on the Impala till 06 bud.
On GM vehicles with drive-by-wire the vehicle will idle low or erratic when the TB becomes dirty,you just clean the throttle blades and the idle becomes normal or stable again.


DEPUTY

slammedR/T
03-16-2010, 04:54 AM
1) When it sits the engine stays idle.
2) It hits hard. Not neck braking hard, but enough to go, "wtf?"

Thanks, I'll take a look at the MAF this weekend, then maybe even clean or replace the TPS if necessary.

The reason the car has an off idle stuble and then "hits" as you say is.The MAF has a hot wire and cold wire,the sensor voltage changes when the hot wire is made colder by moving air across it.when the hot wire gets dirty it dosen't change temp. as fast and causes the stumble.Clean the MAF and it will stop the off idle stumble and will improve MPG prolly 1-2 mpg.I fix MANY impala's and silverados at work this way all the time,dumb ass's try to replace the O2 sensors as sometimes the MAF gets dirty enough to set a lean bank code.


DEPUTY

atvrider07
03-16-2010, 07:28 PM
On gm vehicles that have throttle cables the TB gets dirty and will stick causeing you to press hard to move the throttle blade,you just clean the throttle blade problem solved.Also 02 will be cable not drive by wire that didn't start on the Impala till 06 bud.
On GM vehicles with drive-by-wire the vehicle will idle low or erratic when the TB becomes dirty,you just clean the throttle blades and the idle becomes normal or stable again.


DEPUTY

ok, thanks i will check that out. I was thinking it was drive by wire cuz the throttle doesn't seem to move when cruise control is on but i may be wrong i haven't really looked at it good enough.